The TrackPoint itself works fine. But the three buttons below the spacebar don't. For example if I were to copy these lines, 1-10, using trackpoint buttons it'd start highlighting at 7. If I use the main TrackPad (the part every laptop) and it's buttons it works normal, 1-10:


It's like the button doesn't register right away. I use the TrackPoint ALL the time. I love it and I don't think I can go back to the normal TrackPad, so is there anyway to fix this? An app or setting?

Also, the middle button to scroll isn't working at all I tried:

Middle Button on ThinkPad Not Working with 10.10 update

And put it in /usr/share/... and /usr/lib... neither seem to work. They USED to work. I used to be able to use that method of fixing it, but it seems in 11.04 this doesnt work?

I dont wanna give up on Ubuntu yet...

  • Which ThinkPad do you have? On my T510 both works fine: selecting 1-10 and wheele emulation (enabled using gpointing-device-settings). – htorque May 15 '11 at 19:19
  • I can confirm that everything work on my T410 as well. I used the manual method where we create a file in /usr/share/X11/xorg.conf.d/ as for the selection it also works for me. I understand you concern though, I cannot imagine living without my trackpoint! Do you have another distro installed where you can check if this is a problem with the hardware? – Noz May 15 '11 at 19:58
  • I have an L512... Its like pointing devices just doesn't even work or me or something. Ill try one last try... maybe installs of Wubi are different? – Oscar Godson May 15 '11 at 21:57
  • WTF. the middle button timeout in the trackpoint settings in gpointing-device-settings was set in the middle and it made my left trackpoint button timeout? – Oscar Godson May 15 '11 at 22:01

I got this to work.

First off, all the messed up settings were because gpointing-device-settings (or Pointing Devices in Ubuntu app screens) were set to button 4 in the TrackPoint device settings screen, when it should have been button 2. Once I changed it to button 2 all worked well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.