I am trying to install Ubuntu Server 12.04 LTS on a server that has only USB boot capability (no cdrom, no pxe). I have tried to use 3 different tools but all have failed. The tools I have tried are these:

Linux Live USB Creator 2.8.27: Fails when the installer gets to "Load installer components from CD"

Universal USB Installer Failed fairly early trying to mount /mount/casper (or something like that)

UNetbootin (no version info): Failed when the installer gets to "Load installer components from CD"

How do I (from windows 7 x64) prepare the ISO on to a USB drive to allow me to install ubuntu?


I have checked the install log (/var/log/syslog) to see why it fails and this is what I see:

anna[9142] WARNING **: package retrieval failed
cdrom-retriever: error: Unable to find 'pool/main/l/linux-lts-saucy/block-modules-3.11.0-15-generic-di_3.11.0-15.25~precise1_amd64.udeb'

Checking that folder, the closest resembling file is this:


The only difference is 'amd64' is 'amd6' and '.udeb' is '.ude'.

As more than 1 tool generates this error, could this be a mastering error in the 12.04.4 amd64 ubuntu server iso file?


Try Rufus to make a bootable USB-Drive. Get it here


or here


Since it's portable you don't even need to install this programm and is therefore usable even if you don't have admin rights.

  • Of all the tools I have tried, Rufus seems to properly handle the long filenames and create a working USB Ubuntu flash drive. :)
    – galmok
    Mar 6 '14 at 9:18

The issue seems to be that while the ISO is correct (I assume so), every windows tool seems to be unable to extract the filenames correctly when putting the files onto the USB key. The issue is that the filenames are too long and are simply cut short on Windows.

The issue is reported here:


In the followup, the reporter mounts the image on linux and notices the filenames are correct. But in windows, they are cut short. Why this is so, I cannot say, but now at least I have an explanation. The solution could be to manually fix the names of the 29 filenames or try the mentioned Rufus tool to build the bootable USB drive with.

For reference, opening the ISO file with 7-Zip also shows the filenames cut short.

Joilet doesn't officially support filenames longer than 64 characters. The shortened name is 65 characters long and could be the reason for this problem. Rockridge does not seem to suffer from the same limit, explaining why this iso image seems fine in linux.

I guess every make of linux usb boot drivers need to bend the specifiations of Joliet or implement a Rockridge reader to extract the correct filenames.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.