22

Internet connection is working.

apt-get is working.

Trying to add ppa:cooperjona/lightread but an error has raised:

Cannot add PPA 'ppa:cooperjona/lightread' . Please check that the PPA name or format is correct.

I supposed there is an error in writing or in the PPA.

I tried also the 'ppa:tombeckmann/ppa' but with same error.

  • The issue comes from your system, not the PPA, which works fine for me. – MrVaykadji Mar 5 '14 at 12:01
  • I tried all of this here and still got the same error. – user2117580 Jun 19 '14 at 20:21
  • If anyone of you ends up here and is using a proxy, check this thread instead – eis Nov 17 '15 at 11:27
  • @Anwar: I don't understand how the two are related. The accepted answer here is about certificates and not web proxy servers. – David Foerster May 18 '17 at 22:16
  • @DavidFoerster The linked answer has addressed both the issue and I feel that it's same problem with different answers. – Anwar May 19 '17 at 5:03
33

Open Terminal and run the command

sudo apt-get install --reinstall ca-certificates

It may work, but if doesn't then run

sudo -E add-apt-repository ppa:ppaname/ppa

instead of sudo add-apt-repository ppa:ppaname/ppa

  • 5
    note to reader: sudo -E preserves the user environment, including any proxy config. – eis Apr 29 '16 at 12:04
  • Or if you're on a https restricted network and have to install another root certificate to trust the networks MITM policy, here's something that will help: askubuntu.com/questions/645818/… – Tim Lewis Dec 14 '17 at 2:16
14

I googled the error and find this. So i tried to clone a git as he did there and has the same result.

So to solve this:

sudo apt-get install --reinstall ca-certificates

and things become smooth again :)

  • 6
    I tried this, but the same error exist and it does not work, ain't it odd? – Mohammad Rafiee Dec 6 '14 at 5:20
5

I had this exact error message about checking the PPA name or format. My network was connected and I could ping websites and browse fine.

What I finally figured out was the clock on my computer was set wrong. If it's off more than a small amount, the secure connection will fail and it will report this message. It's very unhelpful.

Check your clock. I set mine and then it immediately worked as expected.

  • Another issue causing this issue is a firewall (like Shorewall) blocking access to the internet. I had the exact same message - there was no other indication that the firewall was blocking.Though it worked after opening a port. – Carsten Schmitz Jun 13 '18 at 10:54

protected by Maythux Nov 17 '15 at 12:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.