Today i upgraded from ATI Catalyst 11.4 beta to 11.5. When i move my mouse to the bottom right corner of the screen the system becomes unresponsive for ~1 second. Everywhere else is fine.

I have no idea what might cause this issue. Thanks for help!


Catalyst 11.6 did not fix that bug. The system still freezes for ~1 second when the mouse cursor is moved to the bottom right corner of the screen.

Update 2:

Finally Catalyst 11.7 is released. Did it fix the bug? No, it's still present. One "workaround" (i won't call it fix, because it has side effects) is to enable the SWCursor in the xorg.conf which causes some flickering of the cursor but the system wont freeze anymore.


Bug Report in AMD Bugzilla

  • Catalyst 11.4: works
  • Catalyst 11.5: freeze when moving mouse to bottom right corner of screen
  • Catalyst 11.6: freeze when moving mouse to bottom right corner of screen
  • Catalyst 11.7: freeze when moving mouse to bottom right corner of screen
  • Catalyst 11.8: works again :)



Option "SWCursor" "true"

to xorg.conf

  • I encountered the same problem upon installing Catalyst 11.5. I'm running a Radeon HD 5770 on an ASUS M4A89TD PRO/USB3. I ended up fixing the mouse problem by reinstalling Catalyst 11.4.
    – user18751
    May 27, 2011 at 22:40
  • I also reinstalled 11.4. Apperantly this bug is not Ubuntu specific and even occurs on Windows. ATI granted Windows-Users a Hotfix, looks like we have to wait for 11.6 and hope its fixed in our Version too.
    – imbaer
    Jun 10, 2011 at 10:18
  • Slowly but surely this is making me angry. Finally Catalyst 11.6 was released and still the bug remains although they say it's fixed in the changelog (at least for Windows 7).
    – imbaer
    Jun 17, 2011 at 10:54
  • 11.7 is out - has anyone tried yet if it fixes this issue?
    – imbaer
    Jul 29, 2011 at 11:52
  • See something is up with either the driver or the card. I know when I made my hackintosh, I had to edit a file to make it say HWCursor = False so, its something weird
    – russjr08
    Jul 31, 2011 at 15:58

4 Answers 4


The newly released ATI Catalyst 11.8 finally fixes the bug!


I can confirm that ATI Catalyst 11.7b fixes the mouse freeze bug.

It also fixes the "external HDMI monitor" bug.

Tested on Ubuntu 11.04 64-Bit with 5x and 6x cards.

Install it and be happy!!!

  • Is 11.7b the default driver from the ATI download page or did you get it from another source?
    – imbaer
    Jul 30, 2011 at 11:22
  • wow - someone showed me the freeze bug with 11.7. Please check the file length of your "fglrx_8.872-0ubuntu1_amd64.deb" file. Is it 35941172 Bytes (no bug) or 35938302 Bytes (mouse freeze)????? Jul 30, 2011 at 13:04
  • where did you download the driver? I always check the amd page: support.amd.com/us/gpudownload/Pages/index.aspx
    – imbaer
    Jul 30, 2011 at 14:00
  • definately not working for me..
    – imbaer
    Jul 30, 2011 at 16:46

Same issue here with Ubuntu 10.04 64bits / Radeon 6450 / Catalyst 11.7

I downgrade to 11.4 and the bug disapears.


Did anyone else try this suggestion from the Unofficial ATI wiki yet?


I haven't found any evidence of any one else having solved the problem this way, and I can't try it myself as I think that for now I will stick to the open source drivers from the xorg-edgers PPA. At least until the problem is fixed in fglrx.

  • 1
    Not working. Besides Xorg.log says: "dri" will be loaded. This was enabled by default and also specified in the config file. I have no idea why that's in the wiki.
    – imbaer
    Aug 7, 2011 at 18:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.