I am getting the following MSG after restarting networking services

stop: unknown instance: networking stop/waiting in ubuntu server 12.04.3

What does lt mean? However I am able to Ping my dns and sites. Can I go ahead and install Samba or I might get problems later because of this error. Please help!

4 Answers 4


The problem you're seeing, as least as it relates to 12.04 Server, is that the networking service is not invoked and kept in a stopped state. I verified this on both my 12.04 servers with the following:

sysadmin@ubuntu-server:/$ service networking status
networking stop/waiting

However, NetworkManager is running:

sysadmin@ubuntu-server:/$ service network-manager status
network-manager start/running, process 1479

and both servers are connected to the network, reachable and functioning fine.

Therefore, if you wish to reload a changed configuration file, you should issue

service network-manager restart

Verify your changed settings through ifconfig. You may install any software you wish unless it requires a static IP address for some reason (very few do).

  • thank you for your help. #Sudo service network-manager restart brings "network-manager: unrecognised service". How do I enable this service? When I run rcconf it does not show any service by that name except network-interface which I have enable as well as network-interface-container and network-interface-security. What other steps am I missing/should do. I have however installed one piece of software an it is working perfectly. Thanking you in advance.
    – Given
    Mar 5, 2014 at 11:15
  • @Given What file did you edit to make the changes to your network config? I will need to edit/delete my answer as I realized network-manager is only active if you have a GUI on your system, which Server typically does not unless you've installed one.
    – douggro
    Mar 5, 2014 at 18:32
  • thanks you gave me the clue. Sudo rcconf did not show that network-manager service was there.sitepoint.com/… showed that there was supposed to be a directory /etc/NetworkManager. My /etc did not have this. So I concluded that network manager was not installed or enable. Despite another site suggesting that in ubuntu it is installed by default I just installed it through apt-get install network-manager. Then rcconf showed network-manager, networking & network-manager status, network-manager status all worked Bravo!
    – Given
    Mar 5, 2014 at 19:23

I fixed such problem adding to the file /etc/network/run/ifstate string


previously file contained only string lo=lo.

Also I created file /etc/network/run/ifup.eth0 with touch and that solved problem, service networking start/stop started to run correctly.


Running /etc/init.d/networking re/start/stop/status is deprecated because it may not enable again some interfaces.

You can still make the same using the command:

sudo ifdown eth0 && sudo ifup eth0

It doesn't mean you can't use Internet so feel free to install whatever there is no problem

  • Hi Hadi thanks. I have done what you have suggested above but the error persists.
    – Given
    Mar 5, 2014 at 11:17
  • what is the error please post what did u do and what is the output
    – Maythux
    Mar 5, 2014 at 11:28

If using VMware, Check and make sure under Network Adapter for the guest VM, the Device Status has "Connected" and "Connect at power on" check. The reboot the VM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.