0

I think this is an original problem, as all suggested solutions I can find online have failed.

I'm running Ubuntu 13.10.

I am a very new linux user, but I'll try to decipher comments.

THE PROBLEM: I just installed Ubuntu. When I try to run sudo apt-get update, I get the response "The method driver /usr/lib/apt/methods/https could not be found."

As suggested on a separate feed, I tried sudo apt-get install apt-transport-https. It says that it can't find that package.

I tried to install nano, something I briefly read about. It couldn't find that package.

I opened Software & Updates, and set it to download from best server. That didn't change anything.

It seems any solution I try leads to "Failed to download repository information" or "cannot find package," which leads to "The method driver etc etc."

Do you guys have any idea what the problem is and how I can fix it? I feel like it there shouldn't be an s at the end of /usr/lib/apt/methods/http. What could I gedit to fix this?

Aha. I was able to manually install apt-transport-https and now update works. There must be something wrong with my software & updates settings, dang. Thanks anyway!

0
  1. Open your terminal and run this command: sudo apt-get install apt-transport-https

  2. Then run: sudo apt-get update

I hope this method work

  • Thanks for the reply! It did not work--install apt-transport-https was met with "cannot locate package." – user254872 Mar 5 '14 at 3:55
  • @user254872 Go to software center, then click edit on menu bar and click software source, change your soruce to "main server" and then run this following command: sudo apt-get update after that try install: sudo apt-get install apt-transport-https. Hopefully this work – Jim Mar 5 '14 at 4:29
  • @user254872 is it worked ? – Jim Mar 5 '14 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.