I have an old 32-bit laptop running Ubuntu Server 12.04. It's connected to my Wifi, and it's always worked perfectly fine - I've been able to SSH into it and stuff.

After a reboot about a day ago, though, I find myself unable to SSH into the machine:

$ ssh user@
ssh: connect to host port 22: Operation timed out

Running sudo service ssh status shows that the SSH server is indeed running:

ssh start/running, process 942

I know that the IP of the machine is, as ifconfig (running on the machine itself) shows:

eth1   Link encap:Ethernet HWaddr 00:13:ce:de:32:48
       inet addr:  Bcast: Mask:

I've tried SSH'ing into it from other machines, and it always times out. I'm using an Airport Time Capsule (newest version) as my main router, but that shouldn't matter as it's always worked before.

Also of note is that I can ping, for example, google.com and receive good packets back. I can also wget things. As far as I can see, the machine has normal access to the Internet.

I've poked around the Internet looking for solutions, and I came across one that suggested that it might be a firewall issue. However, sudo iptables -L -n shows nothing:

Chain INPUT (policy ACCEPT)
target    prot opt source    destination

Chain FORWARD (policy ACCEPT)
target    prot opt source    destination

Chain OUTPUT (policy ACCEPT)
target    prot opt source    destination

The server is also running Apache, and I can't reach that either from any other machine on the local network. I can, however, ping the server from the server itself (ping

Does anyone have any ideas?

  • Just so it's clear, is the laptop connected to your network via Ethernet or WiFi? Your ifconfig states eth1 rather than wlan.. – douggro Mar 4 '14 at 17:21
  • @douggro It's connected my wifi, for some reason it shows up as eth1. – Undo Mar 4 '14 at 17:23
  • 1
    Thought that might be the case. Check for open ports using nmap -v -sT from a remote machine and then nmap -v -sT localhost on the laptop. That should show if the problem lies on the network or on the machine itself. – douggro Mar 4 '14 at 17:41

So as far as I understand, you can reach the internet from the machine in question, but any attempt (ssh/apache/ping) to reach it from within your local network times out.

Since you said this problem occurred after you restarted the laptop, I would also restart your router (dhcp server) to make sure every machine in your local network knows how to contact the

| improve this answer | |
  • I can't believe that the 'generic support call center suggestion' worked, but it did. Thanks! – Undo Mar 4 '14 at 18:06
  • It happens often in my home network too. If I login on the server and ping the router then all is ok, otherwise I have the "unreachable" error. I ended by adding a static route to the server... it seems an arp problem, but I could not dig it out. – Rmano Mar 4 '14 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.