I am trying to install Ubuntu alongside with Windows 8 for three days now. I have a simple notebook with no CD/DVD drive, so I am using a USB stick for it and I used the recommended usb boot creator tool: http://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/. The tool seems to work fine as Windows recognize the USB stick as a Ubuntu install. And I don't have a broken image (I checked the md5 hash).

I was able to boot the USB stick in EFI mode (I saw in this tutorial how to), but after a while in the Ubuntu typical loading screen I get to a terminal text screen with some "kernel panic" stuff and saying that "going back to text mode" or something like that. The problem is that after that nothing happens (need to force shutdown).

I tried to disable UEFI and then boot the computer with the USB stick normally, but then after the typical loading screen I get a white screen with nothing and no options (need to force shutdown to leave, also).

At last, I figured maybe was a distribution problem, so I tried Linux Mint 16 (which is based on Ubuntu, but anyway) and also OpenSUSE. None of them worked. Mint X server crashed (at least I got to a terminal, but that was not what I wanted). OpenSUSE only got me more kernel panic text and I also needed to force shutdown.

I am with this notebook for a few months now and I always wanted to install Linux in it, but was delay because of all the complains I read about this UEFI stuff. Any suggestion?

Thanks in advance.

EDIT: This question is not answered in that post. Like I said, I can't even get to the installation screen.

EDIT 2: I have tried the Ubuntu 12.04.4 in both Legacy mode and EFI mode and always I get to the white screen (after Ubuntu loading) without any further option (except forced shutdown). I also tried the 13.10 version, but the result was the same.

  • check this link askubuntu.com/questions/221835/…
    – sohel4r
    Mar 4 '14 at 13:29
  • I followed that link before and my question is not answered there. I did the step-by-step suggested (in the correct order) and yet I cannot get to the point when I install the system (i can't get to boot the live image). I have installed Linux (Ubuntu, Debian, Mint, etc) quite a few times and I've never experienced the problem I am having now.
    – marcelocra
    Mar 4 '14 at 14:16
  • @infostacker If you already tested the link provided, then please provide some much needed info like what laptop model you are using, more information about what the error actually said and if you already tried filing a bug report about it. Mar 4 '14 at 14:57
  • I have an Acer Aspire E1-522, AMD Quad-core A4-5000 (1.5Ghz). There is not really an error message, just the core dump, which mentions this "kernel panic" and then stop working. I'll run it again and try to provide more details. Regarding filing a bug, since is not working in all three distros I tried, I figured I was doing smtg wrong.
    – marcelocra
    Mar 4 '14 at 16:01
  • 1
    Have you tried the install using unetbootin? This tool is my most trusted usb solution. "kernel panic" could be so many things. it's difficult to say.Reformat usb and try with unetbootin here's the link. unetbootin.sourceforge.net When you boot and the prompt options come up just hit enter. This will start a live session or should! Good luck:)
    – mercurymod
    Mar 4 '14 at 17:49

In order to be able to avoid the white/black screen and get to the live cd I needed to do two things:

  1. Disable UEFI (I couldn't just disable Secure Boot in my machine), so no Ubuntu in EFI mode for me.
  2. Start the installer with two boot parameters: nolapic and nomodeset

In EFI mode I couldn't pass those parameters to the boot, so I was locked to the white/black screen. In the BIOS mode there is an easy way to pass the parameters, and so I could get to the installer and install. The problem is that now I need to choose the system by choosing either UEFI or BIOS, but at least I got both systems running.

  • So, if I may ask, which Ubuntu version is working? Is it implement to all versions? I'm thinking of migrating to 14.04 LTS (currently using 12.04 LTS), but I was force to hold on because there's this UEFI problem that causes a spike of failure reported.
    – user220402
    May 14 '14 at 3:57
  • Actually I gave up not long after that, until I discovered I way to disable Secure Boot on my machine (which was not mentioned anywhere). Then I could install Arch with EFI enabled with no headaches (but those intrinsically related to Arch :) ) and haven't tried Ubuntu again. To figure whether you should try it or not I would point you to this and this. Hope it helps!
    – marcelocra
    May 15 '14 at 1:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.