I'm quite new to Ubuntu, but, sometimes, when I'm on youtube, or doing something else, GPU overheats, and cooler gets very loud, until I close everything I'm doing, than after few seconds GPU gets cooler...

I've be searching on forums for this problem, but I didn't find soultion...

I'm using Dell Inspiron 15 3521:

GPU: Intel HD 4000 (I hope) and ATI Radeon HD 8730M
CPU: Intel Core i3 3227U 1.9GHz

I'm not sure what's overheating, but I think it's the GPU

  • How old is your computer? – Donarsson Mar 3 '14 at 17:25
  • less than one year, I had a problem with old cooler, so they replaced it with a new one... and I can see that many people have this problem – Milos1405 Mar 3 '14 at 17:27
  • It might be the cooler again. It seems to be a general problem with this model and not related to Ubuntu or any other software running on it. You could try opening the computer and clean the cooler (there are good tutorials on YouTube, just search for your notebook model) or get someone to do it for you. – Donarsson Mar 3 '14 at 17:33
  • If you are using a newer kernel maybe this can help: askubuntu.com/a/390050/16395 – Rmano Mar 3 '14 at 19:08

I have the same notebook. If you need your notebook to be cooler you have to disable your discrete graphics card. You can do this by following these instructions:

Run this in terminal (open terminal by pressing ctrl+alt+t )

sudo gedit /etc/rc.local

Paste these before the "exit 0" (replace george with your username)

chmod o+rx /sys/kernel/debug
chown george /sys/kernel/debug/vgaswitcheroo/switch
#Comment next line when you need to turn VGA On By putting # as prefix like this line
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

I have also created a script for fan control but if you use it be carefull because after some time it stops: CPU Fan Control For Dell 3521

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.