5

I updated the Google Chrome version, and since Opera has become my default browser.

In Google Chrome, under the default browser settings, it just says:

"Google Chrome cannot determine or set the default browser."

How do I change this?

3

Go to System Settings --> Details --> Default Applications

And set Google Chrome as default browser. enter image description here (here chromium in my default browser)

  • But why would that happen in the first place? – Pacerier Nov 5 '15 at 19:18
5

To change the default browser:

via command line:

 sudo update-alternatives --config x-www-browser 

and choose the number correspond to google chrome. Now exit and check the problem will be solved from chrome settings(I noticed that a wired thing happen just when Opera become the dfeault).

via GUI:

Click on the dash button in the launcher and search for 'System info'. Then, open 'System info' and move to 'Default applications' section.

enter image description here

2
sudo apt-get install galternatives

Open the program from the start menu. On the left, you will have options to change:

Select: gnome-www-browser & x-www-browser

and change these to Google Chrome.

1

In Xubuntu

Go to Settings --> Prefferd Applications

enter image description here



In my case it's not resolve the issue so I had to run the command

$ sudo update-alternatives --config x-www-browser

Selection Path Priority Status
------------------------------------------------------------
*0 /usr/bin/firefox 40 auto mode
1 /usr/bin/chromium-browser 40 manual mode
2 /usr/bin/firefox 40 manual mode

Press enter to keep the current choice[*], or type selection number:

and select 1

  • 1
    This is similar to Linux Mint MATE: Preferences --> Preferred Applications. – Trevor Robinson Feb 11 '15 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.