The usual situation: Android phones don't like ad-hoc networks, so I'm trying to make Ubuntu act as hotspot with a non-ad-hoc network instead.

I'm on a fresh install of whatever version of Ubuntu the official download page gave me.

I started by following this How do I create a non-adhoc wifi hotspot? guide, but it doesn't work.

( When I run iwconfig I get eth1 instead of wlan0 as my WiFi, so I've replaced wlan0 with eth1 in all the instructions in the link above. And I've had to do sudo apt-get install hostapd to get hostapd, but that seems to have worked)

When I do sudo hostapd -B /etc/hostapd/hostapd.conf I get

nl80211: Failed to set interface eth1 into AP mode nl80211 driver initialization failed. ELOOP: remaining socket: sock=4 eloop_data=0x8413900 user_data=0x8413ea8 handler=0x807c5e0 ELOOP: remaining socket: sock=6 eloop_data=0x8416420 user_data=(nil) handler=0x8086770

This is my first time trying to set anything up in a linux environment, so I have no idea what's going wrong or where to look for clues as to how to proceed.


Just now, I noticed this Failed to set interface wlan0 into AP mode: Intel centrino N1000 Wireless in the list to the right of where I'm typing this question.

I did the sudo iwconfig eth1 mode master. (is the period supposed to be there? tried without, same result) and got Error for wireless request "Set Mode" (8B06) : SET failed on device eth1 ; Invalid argument.

and there's no AP in the list of supported modes. Does this mean I'm doomed?


Trying to dig further on my own, I found http://nims11.wordpress.com/2012/04/27/hostapd-the-linux-way-to-create-virtual-wifi-access-point/ and at one point it tells me to run lspci -k | grep -A 3 -i "network", from which I find Kernel driver in use: ipw2200, which when input in the next command modinfo ipw2200 | grep 'depend' gives me depends: cfg80211,libipw,lib80211. This does not include mac80211 which is the one specifically mentioned in the link as supported. I have not been able to figure out if any of the ones I do get are supported or not.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.