14

I am very new to Ubuntu and to Linux as well. I installed Ubuntu 13.10 on my Dell Inspiron 15R laptop. (Intel i7 processor, 8Gb ram). However the fan constantly running at a very high speed irrespective of the application that I am working on. It does not slowdown for a second even. Could anyone please help me to get this solved. I'll be truly grateful if anyone can help me out in this regard.

2
  • Install the software called 'lm-sensors'. 'sudo apt-get install lm-sensors' then run it in terminal by using the command 'sensors'. It should tell you how hot your laptop is, and that could be the answer why your fans are constantly running. – aroll605 Mar 2 '14 at 23:30
  • 1
    have you solved your problem? I had a similar problem on my HP laptop, where the bios had an option "fan always on" that was enabled. Disabling that radically changed the situation. – user47206 Apr 26 '16 at 13:39
14

I also own a Dell Inspiron 15R laptop, but with an i3 processor and 6GB RAM and running Ubuntu 14.04. I was experiencing the same issue you are and would like to offer you the solution the fan issue on my computer.

I found out via the forums about an application called TLP, which is an autonomous power management tool. Once installed, it began to work immediately and my fans began to run normally. Slightly skeptical, I restarted my computer a few times to verify that the problem was resolved, and it was. My fans were not running at max speed and remaining as such once my computer displayed the GRUB menu and thereon, as they were before I installed TLP.

This site will guide you through installing the application.

UPDATE

I have discovered that TLP was not a complete solution to this issue, or my fan issue. However, I recently found a solution to my fan problem, which seems identical to yours, and I posted it on my thread, https://askubuntu.com/a/537538/311982. But I will post my answer here, for convenience.

Fan speed is normalized by editing the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

in the grub configuration file found at /etc/default/grub so that it reads

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=!Windows 2012".

Follow these steps to try this solution:

  1. Open a terminal, type sudo gedit /etc/default/grub, and press ENTER
  2. Enter your login password and press ENTER (the password will not be displayed as you type it)
  3. Edit the line,

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    such that it reads,

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=!Windows 2012".

  4. Click "Save", wait a few moments for the file to save, then close the text editor.

  5. In the terminal, type

    sudo update-grub

    and hit ENTER

  6. Finally, shut down your computer. Shut it down completely, so don't "restart" it.

Once you turn your computer back on and select the linux operating system whose grub file you edited earlier, your fans should be working normally. This solution has worked for me on Ubuntu, Linux Mint, Elementary OS, and LXLE on a Dell Inspiron 15R 5520 laptop.

-Jordan

4
  • 1
    Thanks for this answer―it looks really promising! What does acpi_osi=!Windows 2012 do, exactly? Thanks! – Numeri says Reinstate Monica Dec 28 '15 at 17:27
  • 1
    Hi Numeri, From what I've read, it makes the kernel report to the BIOS that the computer is running a version of Windows rather than Linux. For some reason, the BIOS may disable ACPI support / power-related features when an OS other than Windows is reported. Interestingly, ACPI was created in collaboration with Microsoft and other companies. Here are links to more info: What is ACPI, Arch Docs...See next comment – user311982 Feb 3 '16 at 11:12
  • Also, here is a reference from this forum about the kernel parameter you mentioned: askubuntu.com/questions/28848/… – user311982 Feb 3 '16 at 11:13
  • Tried but didn't work. fan is still running @3500RPM for 1% CPU usages – Rahul Jan 28 '17 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.