I have been trying to use English-UK thesaurus in LibreOffice but so far cannot get it to work. I have installed mythes-en-us as only it was available in repos. As suggested in some forums I searched for openoffice.org thesaurus, but again US version was available. As a result I can't enable thesaurus when I choose English UK:

LibreOffice Prefs 1

LibreOffice Prefs 2

As instructed elsewhere I tried this:

cd /usr/share/myspell/dicts
sudo ln -s th_en_US_v2.dat th_en_GB_v2.dat
sudo ln -s th_en_US_v2.idx th_en_GB_v2.idx

Still the result is same as shown in above screenshots.

What can be done now?

  • i am trying to create a more general question on the matter (askubuntu.com/q/223557/47206) but my question was closed as duplicate of this here. could you edit yours so as to make it applicable to other languages too? then i could leave mine closed and add more answers here – user47206 Dec 2 '12 at 22:45
  • @Tom Brossman, please see above comment. also, could you consider editing this one in this respect, or otherwise vote to reopen mine? – user47206 Dec 2 '12 at 22:47
  • @cipricus I only learned enough about this issue to produce the below answer. I don't know how to improve it to make it more general. I agree that a more general answer would be best, so please edit mine if you know how. I also just voted to re-open the other one (now showing 4 of five needed votes), if that is best for you. – Tom Brossman Dec 3 '12 at 6:41

Here's what worked for me. I found most of these steps in this blog post, credit to the author for figuring this out.

  1. Download the spelling/hyphen/thesaurus dictionaries you want from LibreOffice's extensions download page.
  2. Install them in LibreOffice Tools -> Extension Manager -> Add and then close LibreOffice.
  3. sudo apt-get install libmythes-1.2-0 hunspell
  4. sudo apt-get install mythes-en-us hunspell-en-us
  5. cd /usr/share/mythes/
  6. sudo ln -s th_en_US_v2.idx th_en_GB_v2.idx
  7. sudo ln -s th_en_US_v2.dat th_en_GB_v2.dat
  8. Open LibreOffice Writer and go to Tools -> Options -> Language Settings -> Writing Aids.
  9. Verify the new thesaurus is selected, then from Writer test it by pressing Ctrl + F7 to bring up the thesaurus dialogue.

Language settings with new thesaurus

Functioning UK thesaurus dialogue

  • this should be set as definitive answer – user47206 Nov 30 '12 at 20:26
  • For Australian English, use sudo ln -s th_en_US_v2.idx th_en_AU_v2.idx and sudo ln -s th_en_US_v2.dat th_en_AU_v2.dat. – Sparhawk Nov 9 '13 at 4:12

This latest version of the Libreoffice Extension "English Dictionaries" works with the latest version of Libreoffice and will hopefully get the thesaurus activated for you.



With each installation of Libreoffice on any of the Distros I have installed for myself or others I have found that the thesaurus always works after I have installed the English dictionaries for Apache OpenOffice-2013.07.31 rather than any extension from LibreOffice.

This makes all the above solutions unnecessary.

This OpenOffice dictionary extension is a year old now and although there are more recent versions here English dictionaries for Apache OpenOffice they always give the error

Extension requires at least OpenOffice.org reference version 4.0

when I attempt to install them.

  • For English-UK, the correct answer is in Mik's

I am posting this answer for other locales:


  • For French, go here to get the French dictionary and install in LibreOffice Writer in Tools-Extensions manager. (The spelling works before installing that, but synonyms context menu does not).

JosephWheatley's answer led me into the right direction: spelling packages are maintained by different people and so the names are pretty different. While en-us packages exist in many variations, this is not for en-gb, so you don't find the right packages by accident. So I searched aptitude for *-en-gb in every category (dictionary, thesaurus, hyphenation) and after installation libreoffice showed en-gb as spellcheck opportunity! :)

sudo aptitude install myspell-en-gb libreoffice-grammarcheck-en-gb mythes-en-gb

works for me on Debian Jessie (because it is Testing it is similar to Ubuntu). The last 2 packages are metapackages (and thus are not! autocompleted nor shown as installed when filtering by ~i for me) and they are linking to

  • libreoffice-lightproof-en
  • mythes-en-us

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.