4

After the most recent update since 3/2/2014 , I cannot listen to music on my ubuntu 12.04 desktop or any other sound from an application. I was able to perform the following test from the command line

~$ speaker-test -Dplug:surround51 -c6 -l1 -twav

speaker-test 1.0.25

Playback device is plug:surround51
Stream parameters are 48000Hz, S16_LE, 6 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 5440
Period size range from 32 to 2720
Using max buffer size 5440
Periods = 4
was set period_size = 1088
was set buffer_size = 5440
 0 - Front Left
 4 - Center
 1 - Front Right
 3 - Rear Right
 2 - Rear Left
 5 - LFE
Time per period = 8.545722

I could hear "front left" from the audio test, but no other sound. Any suggestions?

Below is the audio device information.

~$ lspci -nnk | grep -iA2 audio
00:14.2 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)
    Subsystem: Hewlett-Packard Company Device [103c:2ac8]
    Kernel driver in use: snd_hda_intel
--
01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series] [1002:aa90]
    Subsystem: XFX Pine Group Inc. Device [1682:aa90]
    Kernel driver in use: snd_hda_intel

Below is the AlasMixer information

┌───────────────────────────── AlsaMixer v1.0.25 ──────────────────────────────┐
│ Card: HDA ATI SB                                     F1:  Help               │
│ Chip: IDT 92HD89E2                                   F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
│ Item: Master [dB gain: 0.00]                         Esc: Exit               │
│                                                                              │
│     ┌──┐     ┌──┐     ┌──┐     ┌──┐              ┌──┐     ┌──┐     ┌──┐      │
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      │
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      │
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      >
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      >
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      >
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      >
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      >
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      >
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      >
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      │
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│              │▒▒│     │▒▒│     │▒▒│      │
│     ├──┤     ├──┤     └──┘     ├──┤    Mic In    ├──┤     ├──┤     ├──┤      │
│     │OO│     │OO│              │OO│              │OO│     │OO│     │OO│      │
│     └──┘     └──┘              └──┘              └──┘     └──┘     └──┘      │
│     100    100<>100 100<>100 100<>100          100<>100   100      100       │
│  < Master >Headphon   PCM     Front   Front Mi Surround  Center    LFE       │
└──────────────────────────────────────────────────────────────────────────────┘

I am able to play web videos without crashing or freezing, but no audio can be heard from any web application. I can hear the bongo drums on start up.

I downloaded the following mp3s file and saved into my music folder. I used the following terminal command below to play the mp3 file.

~/Music$ xmms2 play 02\ -\ Frozen.mp3 
~/Music$

I was unable to hear any audio from xmms2 playing Frozen.mp3.

I opened VLC from the terminal and played the mp3 file from the GUI. Below is the terminal feedback from VLC while playing the mp3 file.

~$ vlc
VLC media player 2.0.8 Twoflower (revision 2.0.8a-0-g68cf50b)
[0x2124108] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Got bus address:  "unix:abstract=/tmp/dbus-Wjn42ezXF0,guid=badc6b7aa96a1558a4e1655900000de8" 
Connected to accessibility bus at:  "unix:abstract=/tmp/dbus-Wjn42ezXF0,guid=badc6b7aa96a1558a4e1655900000de8" 
Registered DEC:  true 
"sni-qt/6878" WARN  14:58:38.756 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE 
Registered event listener change listener:  true 
QSpiAccessible::accessibleEvent not handled:  "6"  obj:  QMenu(0x7feec4099610) "" 
QSpiAccessible::accessibleEvent not handled:  "7"  obj:  QMenu(0x7feec4099610) "" 
QSpiAccessible::accessibleEvent not handled:  "8008"  obj:  QObject(0x0)  " invalid interface!" 
QSpiAccessible::accessibleEvent not handled:  "8008"  obj:  QSidebar(0x7feec41ff800, name = "sidebar") "sidebar" 
FIXME: handle dialog start. 
QSpiAccessible::accessibleEvent not handled:  "8008"  obj:  QObject(0x0)  " invalid interface!" 
QSpiAccessible::accessibleEvent not handled:  "8008"  obj:  QListView(0x7feec4205500, name = "listView") "listView" 
QSpiAccessible::accessibleEvent not handled:  "8008"  obj:  QObject(0x0)  " invalid interface!" 
FIXME: handle dialog end. 

I did not hear any sound from VLC.

Below is the analog output file.

~$ analog output
analog: analog version 6.0/Unix
analog: Warning D: Turning all pie charts off because OUTFILE is stdout and
  CHARTDIR is unset
  (For help on all errors and warnings, see /usr/share/doc/analog/docs/errors.html)
analog: Warning F: Failed to open logfile output: ignoring it
analog: Warning R: Turning off empty time reports
analog: Warning R: Turning off empty Request Report
analog: Warning R: Turning off empty File Type Report
analog: Warning R: Turning off empty Directory Report
analog: Warning R: Turning off empty Domain Report
analog: Warning R: Turning off empty Organisation Report
analog: Warning R: Turning off empty Search Word Report
analog: Warning R: Turning off empty Operating System Report
analog: Warning R: Turning off empty File Size Report
analog: Warning R: Turning off empty Status Code Report
<?xml version="1.0" encoding="ISO-8859-1"?>
<?xml-stylesheet href="#internalStyle" type="text/css"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>Web Server Statistics for Debian Linux System</title>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
<meta name="robots" content="noindex,nofollow" />
<meta name="generator" content="analog 6.0/Unix" />
<style type="text/css" id="internalStyle">
h2 {
    background-color: #A0C0F0;
    width: 98%;
    padding: 3px 6px;
}
table {
    text-align: right;
    margin-left: 30px;
    background-color: #D0E0F0;
    border-collapse: collapse;
}
th {
    border-bottom: 1px solid #404050;
    border-right: 1px dotted #606070;
    border-top: none;
    border-left: none;
    padding: 0px 5px 1px 5px;
    font-weight: bold;
    background-color: #A0C0F0;
}
td {
    padding: 0px 5px 1px 5px;
    border-right: 1px dotted #606070;
    border-left: none;
    border-bottom: none;
    border-top:none;
}
td.x {
    font-family: monospace;
    white-space: pre;
}
.xl {
    text-align: left;
    border-right: none;
}
.xr {
    text-align: right;
    border-right: none;
}
.bar {
    text-align: left;
    border-right: none;
}
tr.sub {background-color: #C0C0FF;
    font-style: italic;
}
.repdesc {
    font-style: italic;
}
.repspan {
    font-style: italic;
}
.goto {
    font-size: small;
}
.gensumtitle {
    font-weight: bold;
}
.gototitle {
    font-weight: bold;
}
.runtimetitle {
    font-weight: bold;
}
img {
    border-style: none;
}
a:link {
    color: blue;
    text-decoration: none;
}
a:visited {
    color: purple;
    text-decoration: none;
}
a:link:hover {
    text-decoration: underline;
}
a:visited:hover {
    text-decoration: underline;
}
a:link:active {
    color: red;
    text-decoration: underline;
}
a:visited:active {
    color: red;
    text-decoration: underline;
}
</style>
</head>
<body>
<div class="header"><h1><a name="Top" id="Top" href="http://www.analog.cx/"><img src="/analog/analogo.png" alt="" /></a> Web Server Statistics for <a href="/">Debian Linux System</a></h1>

<p class="analysisspan">Program started at Sun-02-Mar-2014 17:10.</p>
</div>
<div class="gensum"><h2><a name="gensum" id="gensum">General Summary</a></h2>
<p class="goto">(<span class="gototitle">Go To</span>: <a href="#Top">Top</a> | General Summary)</p>
<p class="repdesc">This report contains overall statistics.</p>
<p class="gensumlines">
<span class="gensumtitle">Successful requests:</span> 0
</p>
</div><div class="footer"><p class="credit">This analysis was produced by <a href="http://www.analog.cx/">analog 6.0</a>.
<br /><span class="runtimetitle">Running time:</span> Less than 1 second.
</p>
<p class="goto">(<span class="gototitle">Go To</span>: <a href="#Top">Top</a> | <a href="#gensum">General Summary</a>)</p>
</div>
</body>
</html>

Below is the echo get current desktop command issued twice.

~$ echo $XDG_CURRENT_DESKTOP

~$ echo $XDG_CURRENT_DESKTOP

~$

Below is the GDM session command.

~$ echo $GDMSESSION
mate
~$

Below is the installation attempt of the ubuntu desktop environment.

~$ sudo apt-get install ubuntu-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ubuntu-desktop is already the newest version.
The following packages were automatically installed and are no longer required:
  libgconf-2-4:i386 libatk1.0-0:i386 libidn11:i386 gir1.2-ubuntuoneui-3.0
  libnss3:i386 libdbus-glib-1-2:i386 libncurses5-dev octave-common
  libcairo2:i386 libreadline6-dev libdatrie1:i386 libgdk-pixbuf2.0-0:i386
  libtinfo-dev libpixman-1-0:i386 libcurl3:i386 libxft2:i386 liboctave1
  libthai0:i386 libnspr4:i386 libxss1:i386 libjasper1:i386
  libubuntuoneui-3.0-1 libxtst6:i386 libhdf5-serial-dev thunderbird-globalmenu
  libpango1.0-0:i386 libxcb-render0:i386 librtmp0:i386 libxcb-shm0:i386
  libgtk2.0-0:i386 libreadline-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
~$ 

Attempted to play music file using Rhythmbox and received the following error: "Couldn't start playback Problem occurred without error being set. This is a bug in Rhythmbox or GStreamer."

Below is the F6 command for selecting the generic audio output from alsamixer. The alsamixer terminal posted above is for the default which appears to be the same as the one named HDA ATI SB. There were three options to choose from alsamixer F6 command: "- (default)" , "0 HDA ATI SB" , or "1 HD-Audio Generic", none of which produced any sound from the music files.

┌───────────────────────────── AlsaMixer v1.0.25 ──────────────────────────────┐
│ Card: HD-Audio Generic                               F1:  Help               │
│ Chip: ATI R6xx HDMI                                  F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
│ Item: S/PDIF                                         Esc: Exit               │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│                                     ┌──┐                                     │
│                                     │OO│                                     │
│                                     └──┘                                     │
│                                  < S/PDIF >                                  │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘

The image below is the closest menu I can find to sound settings. This is the closest menu I can find to sound settings

The image below is the selected options tab of sound settings with other menus opened to provide additional information. enter image description here

  • 1
    also add the output to your question: lspci -nnk | grep -iA2 audio also run in terminal: alsamixer and look if it's not muted? can you actually start a song in music player or it's just freeze or crash? – JoKeR Mar 2 '14 at 18:16
  • run sudo apt-get install ubuntu-restricted-extras – JoKeR Mar 3 '14 at 0:18
  • ok and did you try to play mp3 now? – JoKeR Mar 3 '14 at 11:39
  • type in terminal gnome-volume-control and see if you get anything – JoKeR Mar 3 '14 at 11:55
  • the thing is MATE-volume-control what you are using with your environment is not in Ubuntu or Debian repos, I dunno which way you installed Ubuntu obviously not from the official source but follow this thread on Archlinux scroll the page down. – JoKeR Mar 3 '14 at 12:08
2

My audio worked after using the following command:

sudo apt-get autoremove pulseaudio

After updating and rebooting the computer the audio worked. Gayan from Hectic Geek – Application Software & OS Reviews posted an article in the following How to Remove PulseAudio & use ALSA in Ubuntu Linux? Gayan explains in detail the nature of the problem. Gayan explains that Pulseaudio manages the audio of the software to Alsa and Alsa manages the audio to the hardware. Pulseaudio will have mishandling problems when passing the audio data to Alsa once in a blue moon. Simply removing Pulseaudio and allowing Alsamixer to take over removed all audio mishandlings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.