Can help me anyone here ?

Unable to create directory /srv/www/wp-uploads/localhost/2014/03. Is its parent directory writable by the server?

  • what error it gives you
    – nux
    Mar 2, 2014 at 10:16
  • wordpress :D , i had upload header then i got this error
    – ap0calypse
    Mar 2, 2014 at 10:17

2 Answers 2


Firstly, your question is very incomplete. Always remember to describe in detail what you have tried and what happened, along with any other info that you think may be necessary, while asking a question.

Looking at your tags and the message, it looks like your wordpress install is not able to accept file uploads.

This is a linux file system permissions issue. Check the permissions of the folder in the error message and all its parents. They should be writable by the user that apache is running as.

Assuming sane defaults, the user would be www-data. In that case,

sudo chown -R www-data /srv/www/wp-uploads
sudo chmod -R u+w /srv/www/wp-uploads

should do the trick.

Please verify your configuration, since improper usage of sudo, chmod, or chown can be dangerous, even more so when used together.


I totally forgot that this can be a improper wordpress configuration. It is entirely possible that you have chosen the wrong directory for file uploads in wordpress. In which case, this other answer is the one you should be looking at.

You can leave the current configuration as-is, in which case all uploads go to /srv/www/wp-uploads or change the uploads directory to a better* value like wp-content/uploads, copy over all files in /srv/www/wp-uploads and delete the latter.

*better because the uploads live inside the wordpress install directory, instead of web root. It is also a common practice.

  • chmod: cannot access `www-data': No such file or directory
    – ap0calypse
    Mar 2, 2014 at 10:44
  • Sorry, My mistake. That www-data was not needed there. Edited it out.
    – Mahesh
    Mar 2, 2014 at 11:01

Navigate to Miscellaneous Setting :

enter image description here

Just be sure there is not / before wp-content

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.