After executing the following script (I removed all occurrences of tmp, mind you. Or at least I thought I did) and rebooting the system, I'm no longer able to log in through the display manager.


At the beginning, I couldn't even use startx without issuing sudo. This was alleviated by "chmod o+t,ugo+rw /tmp" (which leads me to believe I might have run the wrong (the unmodified) version of the script.

Anyways. After issuing the aforementioned chmod command and rebooting the system, I tried logging in again. While logging in from the terminal functions properly now, LightDM will log in, flash the screen twice and return to the login screen.

Is there anything else I could try?

I ran the script in it's entirety (minus installing the non dev libglw1-mesa)


If you are seeing /tmp in the output of ls -l / command, you can give it proper permission by typing

sudo chmod 1777 /tmp .

  • Well. As I said. /tmp already has proper permissions, so it has to be something else. – user237251 Mar 2 '14 at 10:16
  • You might be correct. There are several .Xauthority files there (SSH cookies, right?) but the main one says "-rw------- root:root" Is it save to set this to "-rw-rw-r--" and my regular user as owner? – user237251 Mar 2 '14 at 11:34
  • I have deleted one of my comment,Use sudo chown username:username ~/.Xauthority and try to login. Also the correct permission of ~/.Xauthority is rw-------. So correct it if needed. – g_p Mar 2 '14 at 11:54
  • Thanks. Everything is back to normal now and I even got the haskell-platform installed (ended up doing it manually, since the script was using sources that wouldn't compile). I'm told that this particular ownership issue might have arisen from the fact that I misused sudo to launch several graphical applications. – user237251 Mar 2 '14 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.