8

Spell-checking works in Kate and Kile, but only for English texts. It is not possible to select another language and dictionary.

The selection of the dict is available for Kate/Kile at: Settings -> Configure Kate/Kile... -> Editor Component -> Editing

The Editing Options contains a tab named "Spellcheck". At the top is a drop down menu named "Default language". The menu is nearly empty. It contains two entries one blank and ellipse "()".

Starting Kate from the command line shows many messages: Enchant dict for "en"

Selecting the "()" as default language exchanges the "en" with "en_ZA".

I installed systemsettings from KDE (I am using ubuntu-desktop/unity). Selecting Locale -> Spell Checker contains the same drop down menu as it is available from Kate and Kile.

I suppose that the problem was introduced during one many upgrades in the past. I installed the system some years ago ...

Any ideas how I get a German language and dictionary?

Using gedit the German dict is selectable.

These are my installed dictionaries/language packages:

ii  aspell-de                20120607-1                        all   German dictionary for aspell
ii  hunspell-de-de           20120607-1                        all   German dictionary for hunspell
ii  hyphen-de                1:3.3.0-2ubuntu3                  all   German hyphenation patterns for LibreOffice/OpenOffice.org
ii  kde-l10n-de              4:4.11.5-0ubuntu0.1               all   German (de) localization for KDE
ii  language-pack-de         1:13.10+20131012                  all   translation updates for language German
ii  language-pack-gnome-de   1:13.10+20131012                  all   GNOME translation updates for language German

System is an up-to-date Ubuntu 13.10 Saucy, 64-bit. I am still facing this problem after update to 14.04 Trusty. This is still true on 14.10 Utopic.

Any ideas about how to get the German dictionary into Kate?

8

Just install for example hunspell-de-de package, restart Kate and you should be good to go, German added to spelling dictionaries.

sudo apt-get install hunspell-de-de

I used muon package manager myself.

  • 1
    As shown in my question hunspell-de-de is installed. – Christian Feb 25 '15 at 14:37
0

I haven't used KDE in years, but is it conceivable that the options are buried somewhere in System Settings -> Regional & Language?

  • Thank you for your help. You are right. There is a tab named "Country/Region & Language". I checked the the tab named language. But this language setting influences the localization of the applications and not the used dictionary for spell-checking. My System Settings are now called "Systemeinstellungen". The selection of a German dictionary is still not possible. One additional remark: I am not using KDE, only some really good apps from KDE. I tried the Gnome equivalent to Kile named Gummi. It has a working spell-checker but crashes nearly immediately when opening a 20 pages document 8-( – Christian Mar 1 '14 at 18:10
  • Systemeinstellungen sounds familiar ;) Too bad I could be more helpful :-\ – Klaus-Dieter Warzecha Mar 1 '14 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.