1

Im having trouble with my keyboard layout. I have a MacBook Pro (June 2006) with 13.10 installed. I choose Norwegian Machintosh as keyboard layout, but I cant figure out how to create the third level characters, like curly braces.

It also seems that pipe is mapped to the key left of 1, so I have no idea where to find apostrophe.

The layout in the "Keyboard Layout Chart" doesnt even look like my keyboard.

How can I get a correct keyboard layout?

1

I used lxkeymap under Lubuntu 13.10.

sudo apt-get install lxkeymap
sudo lxkeymap

Tools > Show/Hide Profiles > Options > Key to switch to third level > right windows button

(unsure of the exact English translation for the last two points)

The right windows key corresponds to the right apple key. Now everything works for me.

0

It seems that keyboard mapping / configuration has changed in 13.10, and the "right" way of doing this would be:

  1. Run sudo dpkg-reconfigure keyboard-configuration
  2. And on page four choose which button you want to use for third level (Left Alt for me)

This give me similar keyboard mapping for third and fourth level as in Mac OS X.

You can also do this through the System Settings | Keyboard | Shortcut Tab | Typing. And change the Alternative Characters Key to Left Alt.

  • Hakon, I tried to fix this problem using your solution and i think i effed up. I on longer have the three last chacaters ae oe aa, is there a way to reset the settings i did in sudo dpkg-reconfigure keyboard-configuration... pls help – Pådne Mar 6 '16 at 21:53
  • It sounds like you didn't choose a Norwegian keyboard layout during configuration. – Håkon K. Olafsen Mar 25 '16 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.