0

I'm using Firefox in Xubuntu.

I deleted my history on firefox, however, whenever I write something in the search bar, I still see my history there.

How should I completely delete my history? (I already tried using BleachBit, but it didn't help).

EDIT: Guys, I obviously tried to delete my history by going to ctrl+shift+del and deleting everything. As I said "I deleted my history on firefox".. That's not working. I mean, it does delete the history, but it doesn't delete the suggestions in the address bar.

  • go to history --> recent history now select the all check box and time range to clear: Everything select that and click the clear button – Premkumar Mar 1 '14 at 12:44
  • @Premkumar, see my edit please. – Crake Mar 1 '14 at 12:57
  • can u tell what you exactly looking for? above will help you after clearing history still it listing site mean close and reopen the browser.If you not want to store the site mean you can use the open new private window – Premkumar Mar 1 '14 at 13:02
  • @Premkumar, I didn't understand your point. What am I looking for? I'm looking to completely delete my history, cookies, etc, etc, in order to have the address bar not show me certain websites in the suggestions dropdown list. – Crake Mar 1 '14 at 13:04
  • @Crack oh fine first do this ctrl+shift+del and in time range to clear select everything and in details select all check box then close you firefox and open it agian and tell me if still its showing means – Premkumar Mar 1 '14 at 13:08
2

Open Firefox and press ctrl+shift+del. It will open a window .

Select everything in time range to clear drop down list.

Also check all options by expanding the details.

  • Please, check my edit. – Crake Mar 1 '14 at 13:04
  • Are you sure it is showing history . It may be showing you bookmarks. Pls make sure what you are showing is not in bookmarks. Check it in Bookmarks -> Show all bookmarks . – g_p Mar 1 '14 at 13:39
0

You can set the browser.urlbar.autoFill option to false on the about:config page to disable autocomplete.

enter image description here

enter image description here

And for search options, disable the Show search suggestions.

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.