8

So I create presentations using LaTeX and the Beamer class. This allows me to embed videos (.mp4, .avi, .gif) formats in my presentation. These seem to play well in full versions of acrobat reader but these videos DO NOT play in Okular.

Is there something else I should do to configure Okular? Is this a LaTeX question or a Ubuntu question? ;)

Code snippet to embed video in latex

\documentclass[bookmarks=true]{beamer}
\setbeamertemplate{footline}[page number]
\setbeamercolor{structure}{bg=yellow, fg=black}
\usepackage{times}
\usepackage[T1]{fontenc}

\usepackage{movie15}
\usepackage{fourier-orns}

\begin{document}
    \begin{frame}
    \frametitle{Slide Title Here}

    \centering
    \includemovie{6.5cm}{6.5cm}{./figures/Video.avi}

    \end{frame}
\end{document}
6

The following worked for me:

  1. Change the backend of Phonon (which is used by Okular to play videos) to the VLC one. For me it sufficed to install the respective package:

    sudo apt install phonon-backend-vlc
    

    On newer versions of Ubuntu, the crucial package is phonon4qt5-backend-vlc.

  2. Use multimedia instead of movie15:

    \documentclass{beamer}
    \usepackage{multimedia}
    
    \begin{document}
        \begin{frame}
            \movie[poster, height=6.5cm, width=6.5cm]{}{/figures/Video.avi}
        \end{frame}
    \end{document}
    
  • Doesn't help. The videos are still not showing – Rubi Shnol Jul 10 '20 at 11:04
  • @RubiShnol: It’s hard to help without any specifics, but this could be the symptoms of the EoL of Flash EoL – on which all multimedia embedding in PDFs is based. – Wrzlprmft Jul 10 '20 at 11:21
  • It works in previous releases of Okular. They were okay, but crashed when exiting presentation mode (known bug). With the new one, 1.10, the videos are no longer playable. I embedded an mp4 not using flash (used multimedia package). Support of flash will end soon anyway – Rubi Shnol Jul 10 '20 at 11:36
  • @RubiShnol: As far as I know, every embedding of multimedia content in PDFs is eventually based on Flash, including the multimedia package. – Wrzlprmft Jul 10 '20 at 11:53
  • Not sure about that. What version of Okular are you using? – Rubi Shnol Jul 10 '20 at 12:14
1

Movie15 is actually absolete now. You'd better use media9, however chances are this also won't work since a lot of pdf-readers just won't play video's for security reasons.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.