I recently found my old Dell Latitude D520 and I decided it would be a learning experience to try and dual boot Ubuntu on it and play with a new operating system. I installed Ubuntu but to my surprise it won't connect to any network, wired or not. It didn't seem to recognize any network cards at all on my laptop.

Now, I'm an utter noob at Linux and Ubuntu and I've got no clue how to install any types of drivers. Could somebody help me here, giving me explicit instructions?

Edit 1: I downloaded Ubuntu 12.04.4. It is my assumption that no network cards are being recognized because Ubuntu is telling me there are no network devices available. As well, plugging in an Ethernet cord doesn't seem to do anything as I still cannot connect to the internet or my home network.

Output of ifconfig:

Link encap:Local Loopback
inet addr: Mask: inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:32 errors:0 dropped:0 overruns:0 frame:0 TX packets:32 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:2608 (2.6 KB) TX bytes:2608 (2.6 KB)

Edit 2:

Output of lspci -nn | grep -e 0200 -e 0280

02:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX [14e4:170c] (rev 02) 0c:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)

  • What version of Ubuntu are you using? Please edit that into your question. How are you determining that no network cards are recognised? Ethernet cards are nearly always recognised - maybe you have networking disabled from the desktop network icon? What is the output of ifconfig? Please paste that into your question.
    – halfer
    Mar 1, 2014 at 6:03
  • Please open a terminal Ctrl+Alt+t and run: lspci -nn | grep -e 0200 -e 0280 The pipe symbol | is on the right side of my keyboard on the same key with \. Edit your question to add the results.
    – chili555
    Mar 1, 2014 at 16:30
  • I've edited the post including the Ubuntu version as well as the output of both of the above commands. Thanks for the help so far.
    – Bojan
    Mar 1, 2014 at 17:36

1 Answer 1


I've figured out how to do it. I should preface this saying that I don't know if this is the correct way of doing it, but it worked for me so I decided to post it.

First I did:

sudo apt-get remove bcmwl-kernel-source

Then I followed the tutorial here: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

I used the "b43 - No Internet Access" method and it worked!

Good luck to anybody else who encounters this problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.