I'm very keen to get started using Ubuntu 12.04 but am struggling with getting the wifi working on my Dell XPS l501x machine.

The problem is that I can't select a wireless network because it says device not ready when I click on the wifi signal up the top right, don't have enough reputation to include an image sorry. I've tried to solve the issue following the instructions at ubuntu help . Below is the output of the key commands from these instructions, I would really appreciate if someone could offer me some advice.

darren@minion:~$ nm-tool
NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
Type:              Wired
Driver:            r8169
State:             unavailable
Default:           no
HW Address:        F0:4D:A2:5B:E5:33

Carrier Detect:  yes

Wired Properties
Carrier:         off

- Device: wlan0 ----------------------------------------------------------------
Type:              802.11 WiFi
Driver:            iwlwifi
State:             unavailable
Default:           no
HW Address:        00:26:C7:9A:53:E6


Wireless Properties
WEP Encryption:  yes
WPA Encryption:  yes
WPA2 Encryption: yes

Wireless Access Points

darren@minion:~$ sudo lshw -C network
[sudo] password for darren: 
*-network DISABLED      
   description: Wireless interface
   product: Centrino Wireless-N 1000 [Condor Peak]
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:04:00.0
   logical name: wlan0
   version: 00
   serial: 00:26:c7:9a:53:e6
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=3.11.0-17-generic         firmware= build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   resources: irq:56 memory:f0500000-f0501fff
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:09:00.0
   logical name: eth0
   version: 06
   serial: f0:4d:a2:5b:e5:33
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:53 ioport:5000(size=256) memory:f0404000-f0404fff memory:f0400000-f0403fff

darren@minion:~$ lsmod
Module                  Size  Used by
rfcomm                 74718  12 
bnep                   24107  2 
parport_pc             32866  0 
ppdev                  17711  0 
snd_hda_codec_hdmi     41736  4 
arc4                   12573  2 
iwldvm                244387  0 
mac80211              623607  1 iwldvm
joydev                 17613  0 
snd_hda_codec_realtek    57149  1 
nouveau               979899  3 
ttm                    84837  1 nouveau
snd_hda_intel          57134  5 
lp                     17799  0 
snd_hda_codec         194817  3           
drm_kms_helper         53237  1 nouveau
uvcvideo               82247  0 
iwlwifi               179516  1 iwldvm
videobuf2_core         40815  1 uvcvideo
videodev              138562  2 uvcvideo,videobuf2_core
i7core_edac            24565  0 
videobuf2_vmalloc      13216  1 uvcvideo
parport                42466  3 parport_pc,ppdev,lp
drm                   306660  5 nouveau,ttm,drm_kms_helper
edac_core              62944  1 i7core_edac
snd_hwdep              13613  1 snd_hda_codec
snd_pcm               107140  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
videobuf2_memops       13362  1 videobuf2_vmalloc
mei_me                 18418  0 
lpc_ich                21163  0 
snd_seq_midi           13324  0 
snd_rawmidi            30416  1 snd_seq_midi
dell_wmi               12761  0 
sparse_keymap          13890  1 dell_wmi
psmouse               104093  0 
mei                    78537  1 mei_me
dell_laptop            17425  0 
mac_hid                13253  0 
btusb                  28374  0 
dcdbas                 14936  1 dell_laptop
i2c_algo_bit           13564  1 nouveau
intel_ips              18520  0 
mxm_wmi                13021  1 nouveau
wmi                    19256  3 nouveau,dell_wmi,mxm_wmi
serio_raw              13413  0 
video                  19574  1 nouveau
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                66061  2 snd_seq_midi,snd_seq_midi_event
bluetooth             391726  24 rfcomm,bnep,btusb
snd_timer              29989  2 snd_pcm,snd_seq
snd_seq_device         14497  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    73753  21       
cfg80211              499466  3 iwldvm,mac80211,iwlwifi
soundcore              12680  1 snd
snd_page_alloc         18798  2 snd_hda_intel,snd_pcm
ahci                   30063  3 
r8169                  73299  0 
libahci                32118  1 ahci
mii                    13981  1 r8169

darren@minion:~$ sudo iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off

darren@minion:~$ sudo iwlist scan
eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Network is down

darren@minion:~$ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Wild Man helpfully suggested I run his script, see comment below. The results of this can be seen here. Upon seeing the results I was asked the run another command:

darren@minion:~$ md5sum /lib/firmware/iwlwifi-1000-5.ucode
9f81a060ed274f76cd605295da77f7a6  /lib/firmware/iwlwifi-1000-5.ucode

I'll edit this answer again once Wild Man responds.

  • You can add an image by uploading it to the internet and then linking it here. Commented Feb 28, 2014 at 14:23
  • It is safe to run it was written by me and some good friends it will help diagnose your wireless issue. Paste this command in a terminal wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named (wireless-info.txt, or wireless-info.txt.tar.gz) in your home folder paste the contents of the file here pastebin.com then paste the link back here. No internet then go to this link for running the script without internet. <ubuntuforums.org/showpost.php?p=12350385>
    – Wild Man
    Commented Feb 28, 2014 at 18:12
  • Hi @WildMan , thanks for your comment. I ran your script and the output can be found here pastebin.com/jYeBGh3n.
    – darrenjl
    Commented Feb 28, 2014 at 21:00
  • @WaldirLeoncio That is how it tried to do it originally but it said I needed ten rep points when I tried to submit my question?
    – darrenjl
    Commented Feb 28, 2014 at 21:05
  • You're right, this page makes it clear that a new user can only post one link per post. If you think the image would help more than that Ubuntu Help link, you can replace one link with the other. Commented Feb 28, 2014 at 21:14

1 Answer 1


I'm going to stay a ubuntu user, I finally figured it out. The solution has been adapted from the answer on another askubuntu question here. My code in the end was slightly different so I'm including it here but the credit must go to the author of the original answer and the explanation can be found there (I suggest an upvote and a comment if you use it, I don't have the reputation to do it yet but I will ASAP). The link for the firmware in the original answer is out of date so I downloaded it at http://pkgs.fedoraproject.org/repo/pkgs/iwl1000-firmware/iwlwifi-1000-ucode- After you have downloaded the firmware navigate to it and use the following commands:

tar xzvf iwlwifi-1000-ucode- 
sudo mv /lib/firmware/iwlwifi-1000-5.ucode /lib/firmware/iwlwifi-1000-5.bak
cd iwlwifi-1000-ucode-
cp iwlwifi-1000-3.ucode iwlwifi-1000-5.ucode
sudo cp iwlwifi-1000-5.ucode /lib/firmware
sudo modprobe -r iwlwifi
sudo modprobe iwlwifi
dmesg | tail -n20

The main difference between this and the linked answer is in the modprobe command I had to use iwlwifi instead of iwlagn.

  • glad you got it sorted out ok. Commented Mar 1, 2014 at 15:22
  • That is what I thought was wrong it is the reason I asked for information on your firmware. Sorry I did not get back sooner, life is busy.
    – Wild Man
    Commented Mar 1, 2014 at 20:31
  • @WildMan your comments led me to the solution, thank you.
    – darrenjl
    Commented Mar 2, 2014 at 1:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .