I am currently running Kubuntu 10.04 on a Lenovo T500 laptop with ATI Radeon HD 3650. I want to switch to Gnome with Unity, but encountered the following impossible situation:

  • As reported in this bug, and in several other reports, Ubuntu 11.04 won't boot when using the open-source ATI driver. It crashes before even starting. Therefore, I am forced to use the FGLRX driver.
  • However, Unity refuses to work with the ATI proprietary driver - It simply kicks back to the classic Gnome desktop. Running unity_support_test, as suggested here, terminates without any message, with exit code 139.

Is there any known good configuration or workaround that will let me run Unity on this Radeon card, preferably that been tried and tested?

closed as off-topic by bain, Eric Carvalho, Lekensteyn, Panther, belacqua Jul 1 '14 at 0:27

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eric Carvalho, belacqua
  • "This question is specific to an end of life Ubuntu release. These are no longer supported and are therefore off-topic here. To upgrade, see: How to install software or upgrade from old unsupported release?" – bain, Lekensteyn, Panther
If this question can be reworded to fit the rules in the help center, please edit the question.

  • my big and only problem in linux or debian graphics card driver I didn't found any solution yet for this and best thing to don't install your video card driver or you will be force problem or crash and i can't run compiz fusion from this problem i tried driver from main site ati and open source driver from canonical and no way – Mahmoud20070 Feb 22 '12 at 8:38

You could try adding


to the /etc/environment file. I have a GeForce FX 5200, and my driver is blacklisted, but I forced Unity and it works. Not the best performance, though.

However, the best solution would be to use Unity 2D, which is basically the same, but designed for non-accelerated graphics.


Did you try installing the newest (11.4) FGLRX from ATI Driver Download site? In my case it solved all problems.

  • The newest is 11.5. – Reda Lazri May 14 '11 at 20:41

I am using Radeon HD 4670 and I don't have either problems stated above. Open source driver works with Unity off the install. I switched to ATI 11.04 fglrx and it works fine except for Plymouth as usual.

  • That's weird -- I'm using the HD 4670M (Sony Vaio VPCSB) and I'm experiencing the exact same problems as described by the OP. – Konrad Rudolph May 22 '11 at 20:47

Not sure if this has been answered, but I believe the T500 has switchable Intel/ATI graphics. You need to force you system to use the discrete graphics in the BIOS. Right now, it sounds like you're trying to boot using the Intel graphics, which is the default under the "switchable" setting.

  • 1
    That's worth investigating, I run Unity on a T510 with Intel graphics with no real problems. – ppetraki Feb 22 '12 at 9:31

In 12.04, fglrx new version quite good for my ati 5770. Unity works smoothly. Opensource radeon driver works well too, but it can't control power management(temperature) well.

Try 12.04 daily live image or 11.10 with usb stick. Make sure persistent area on for save change after reboot. fglrx needs reboot to work.

Don't forget update.

Not the answer you're looking for? Browse other questions tagged or ask your own question.