0

New here, be gentle...

I am setting up a server using Ubuntu Server 13.10 64 bit. So far all went well, but now running into a problem during installation of libssh2-php.

Setting up libssh2-php (0.11.3-0.1build2) ...

Creating config file /etc/php5/conf.d/ssh2.ini with new version
cp: cannot create regular file â/etc/php5/conf.d/ssh2.iniâ: No such file or directory
dpkg: error processing libssh2-php (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 libssh2-php
E: Sub-process /usr/bin/dpkg returned an error code (1)

Tried sudo apt-get remove --purge libssh2-php followed by reinstalling, no luck.
When I check /etc/php5/, there is a /etc/php5/apache2/conf.d and a /etc/php5/cli/conf.d directory but no /etc/php5/conf.d directory.

Edit php version 5.5.3

Any suggestions welcome... Thanks!

  • What was the output of sudo apt-get install -f after reinstalling? – Avinash Raj Feb 27 '14 at 19:37
  • I suggest you file a bug report. You can try , as a work around, sudo mkdir -p /etc/php5/conf.d/ && sudo install libssh2-php. If that fails, run sudo touch /etc/php5/conf.d/ssh2.ini && sudo install libssh2-php – Panther Feb 27 '14 at 19:37
  • @AvinashRaj - /etc/php5/conf.d is the config directory for php5 and usually contains things such as php.ini The "â" is a translation problem see stackoverflow.com/questions/1461907/… – Panther Feb 27 '14 at 19:42
  • sudo apt-get install -f results in the same error. – user253031 Feb 27 '14 at 19:52
  • Manually creating /etc/php5/conf.d does solve the issue, no need to touch the ini file first. Thanks for your suggestion! – user253031 Feb 27 '14 at 19:53
3

This is a bug.

As a workaround:

sudo mkdir -p /etc/php5/conf.d/ 
sudo apt-get install libssh2-php

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.