2

I installed Ubuntu 12.04 from Windows 7 via windows installer. It completed (I guess) successfully.

The problem occurs when I start Ubuntu. Neither mouse nor keyboard work (both usb). I can't type in the password.

Sorry if the question is a duplicate.

update: Keyboard and Mouse work on USB 3.0 ports but not on others. What should I do? I don't want to waste 3.0 on keyboard and mouse.

1
  • Thank you very much Invader Zim! I have been having this issue for some time now and this resolved it, I have a Gigabyte motherboard :)
    – user259972
    Apr 2, 2014 at 12:12

1 Answer 1

1

Did you try different USB ports?

If they all do not work, try to SSH into your machine. If you have access to your home router, you can see what computers are connected with their IPs. Check your

ls /dev/input/by-id/

to see if your USBs are even detected. You will see the names of your devices attached. If they are not there, this may be a USB driver issue.

Update:

OP has a new Gigabyte motherboard that has an option called IOMMU which is disabled by default. Enabling it solves the problem.

8
  • I tried different USB ports although they all work (just to be sure). Keyboard and mouse fail to work only when I choose Ubuntu, otherwise they work (Windows, BIOS etc). I'm new to Ubuntu (and Linux). Checking if USBs are detected should be done from Ubuntu? Because I can't do anything in Ubuntu, I'm stuck at the log in screen Feb 27, 2014 at 17:13
  • Do you have more than one computer? Also, can you boot into recovery mode?
    – Mr.Lee
    Feb 27, 2014 at 17:17
  • I have one computer. I don't know if I can boot into recovery mode Feb 27, 2014 at 17:18
  • You don't know how to or you can't?
    – Mr.Lee
    Feb 27, 2014 at 17:19
  • 2
    Went to recovery mode, keyboard didn't work in recovery menu. Found the solution. There is a BIOS option called IOMMU Controller with newer Gigabyte motherboards, and it is disabled by default. Enabling it solves the problem. I should have done more research. Found the solution here: unix.stackexchange.com/questions/72625/… Sorry for wasting your time. Can you please post the above as an answer and I will accept it. Feb 27, 2014 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.