21

After installing TeamViewer x86 on Ubuntu, it will not start automatically on boot, even when telling it to do so via the application settings ("Start TeamViewer with system"). How do I make sure TeamViewer starts with the system, before even logging in?

28

TeamViewer provides a script called teamviewerd.sysv available in /opt/teamviewer/tv_bin/script. Here's an excerpt:

#!/bin/bash
#
# /etc/init.d/teamviewerd
#
# chkconfig: 2345 95 05
# description: daemon for TeamViewer
#
# processname: teamviewerd
# config: /etc/teamviewer/global.conf
# pidfile: /var/run/teamviewerd.pid

### BEGIN INIT INFO
# Provides:          teamviewerd
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Required-Start:    $all
# Required-Stop:     $local_fs $network $named
# Short-Description: TeamViewer remote control daemon
# Description:       TeamViewer remote control daemon
### END INIT INFO

All you need to do is make sure this script runs on startup. Making sure of this is relatively simple, just copy it to /etc/init.d like so:

cd /opt/teamviewer/tv_bin/script
sudo cp teamviewerd.sysv /etc/init.d/

Don't forget to make the script non-writable to anyone but the owner!

sudo chmod 755 /etc/init.d/teamviewerd.sysv

Then run

sudo update-rc.d teamviewerd.sysv defaults

The service will now start automatically with each boot. If you don't feel like rebooting, you can start the service manually with:

sudo service teamviewerd.sysv start
1

I was using Teamviewer version 9 and there is option Start TeamViewer with system. By enabling this option, teamviewer register as a system service and automatically start with the system. Reboot system and it starts with the system before logging in.

enter image description here

In Teamviewer 11, it can be enabled from the main desk.

enter image description here

  • 2
    Are you sure that running teamviewer renders the same result as running the daemon? – pzkpfw Jul 6 '15 at 8:34
-1

Create a soft-line of teamviewer in your run level file location. You can do that by using:

sudo ln -s /usr/bin/teamviewer /etc/init.d/

or if your system is using systemctl then use:

sudo ln -s /usr/bin/teamviewer /etc/rc.d/rc5.d/

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.