It's my first question and I am pretty much desperate by now. So please look upon any errors likely to occur in my question.

So, I had Ubuntu 12.10 running alongside Windows 7 (which is the default OS). A few months back I tried do-release-upgrade and before it finished, I aborted it.

2 days ago I ran sudo apt-get update && sudo apt-get upgrade since Software Updater kept saying

"not all updates can be installed".

So when upgrading finished, I rebooted my computer and got a total blank screen after logging in. I tried everything I could find on the net (uninstalling and then installing lightdm again seemed somewhat to work, at least the screen wasn't black anymore). But what came wasn't much of an improvement. The dash was gone, along with the top bar. It was a total wallpaper, the whole screen. Hitting ctrl+alt+F1 brought the terminal and that was the only thing that worked correctly. With that I installed CompizConfig Settings Manager and after a lot of fooling around managed to get the dash back, but no top panel. But it was nothing near right. All open applications show a question mark instead of the app logo in the dash. The menu is always on top of every window, instead of when I hover my mouse there. What is worst about the whole thing, is that the log in screen still shows Ubuntu 12.10, even though the terminal says it's 13.10 and running do-release-upgrade brought the message that no upgrade is available.

Brothers and sisters, what can be done?

  • You can not upgrade from 12.10 to 13.10 in first place. Did you edited a line in your sources list to force this? – xangua Feb 27 '14 at 16:40
  • Looks like you can, but it's a bit painful. No, I didn't do anything like that. – nos_feratu Feb 28 '14 at 7:22

I would like to suggest to boot your system into recovery mode. Try to fix broken packages as shown below.

Choose Drop to root shell prompt after booting Ubuntu in recovery mode. Execute following commands in terminal.

mount -o remount,rw / 

sudo rm /var/lib/apt/lists/* -vf   

sudo apt-get update 

sudo apt-get install -f && sudo dpkg --configure -a 

sudo apt-get --fix-broken install

sudo apt-get clean && sudo apt-get autoremove && sudo apt-get autoclean
| improve this answer | |
  • Thanks, that worked, plus apt-get upgrade and dist-upgrade. – nos_feratu Feb 28 '14 at 7:18
  • Welcome friend, I am Glad, it solved. – KK Patel Feb 28 '14 at 12:20
  • Now on every boot it says I have little space left on my computer. I cleaned some disk space following the instructions from here and still I got Found Ubuntu 12.10 (12.10) on /dev/sda9. Would really like to know if it can be removed and how. Thanks again. – nos_feratu Mar 1 '14 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.