10

I encounter this error:

The path /usr/src/linux/include is not an existing directory.

Hi there are still issues as listed below. Please advise

ronald@ronald-virtual-machine:~/Desktop/vmware tools/vmware-tools-distrib$ sudo ./vmware-install.pl
[sudo] password for ronald:
A previous installation of VMware Tools has been detected.

The previous installation was made by the tar installer (version 4).

Keeping the tar4 installer database format.

You have a version of VMware Tools installed. Continuing this install will 
first uninstall the currently installed version. 
Do you wish to continue? (yes/no) [yes]

Error: Unable to execute "/usr/bin/vmware-uninstall-tools.pl.

Uninstall failed. Please correct the failure and re run the install.

Execution aborted.

ronald@ronald-virtual-machine:~/Desktop/vmware tools/vmware-tools-distrib$ `chmod +x /usr/bin/vmware-uninstall-tools.pl`

chmod: cannot access `/usr/bin/vmware-uninstall-tools.pl': No such file or directory

10 Answers 10

10

This also happened to me when I interrupted vmware tools upgrade. it seems, the first thing the upgrade does is delete all files in the system. the uninstall script being the first one and that's why you can't find it.

I don't understand why the installation gets interrupted+ if the uninstall script is not found (for me, that's just a bad decision), but the mounted device comes with its own script which you can use to delete everything. a simple

locate vmware-uninstall

outputed its location and for me it was in

/home/my_username/Desktop/vmware-tools-distrib/bin/vmware-uninstall-tools.pl

For you, the only difference should be ronald instead of *my_username*. Hope that helps.

| improve this answer | |
5

Run sudo rm -R /etc/vmware OR sudo rm -R /etc/vmware-tools

this will remove settings and you can install new one.

| improve this answer | |
  • 1
    This was the answer for me, although I renamed the directory rather than removing it. – formica Apr 3 '17 at 23:29
3

you should install the header first

apt-get install linux-headers-2.6.10-5-386(name of your kernel)

and then enter on the vmware installation:

/usr/src/linux-headers-2.6.10-5-386/include

It should help

| improve this answer | |
2

It appears that vmware is trying to uninstall the older version before installing the newer one, but is failing to do so.

  1. I would manually uninstall the old version of vmware tools by typing the following command into the terminal:

    sudo apt-get remove vmware
    

Note: the word "vmware" is just a guess as to what the name of this package is. If this gives you an error like "Unable to locate package" then try changing the word vmware to whatever you think the package name is.

  1. Once vmware is unstalled, try installing the newer package.
| improve this answer | |
2

What worked for me was the last answer provided in this thread by Amir Arian -- so simple and yet I could not find it easily elsewhere.

If you followed VMware instructions, you extracted the VMware tools to /tmp. So, you should have /tmp/vmware-tools-distrib. Inside that you have a bin directory and there is the vmware-uninstall-tools.pl file.

cp /tmp/vmware-tools-distrib/bin/vmware-uninstall-tools.pl /usr/bin/

Then run the installer once more:

/tmp/vmware-tools-distrib/vmware-install.pl

It will come back with an error that might look like this:

"Can't exec "/etc/vmware-caf/pme/install/preupgrade.sh": No such file or directory at /usr/bin/vmware-uninstall-tools.pl line 4115."

However, the installer will keep working and eventually proceed to the installation phase.

| improve this answer | |
1

I solved this same problem doing fixes below. I would summarize issue as aborting a vmware-install when kernel headers not found. Pressing Ctrl-C during vmware-install can cause the "Error: Unable to execute "/usr/bin/vmware-uninstall-tools.pl." in several cases in general.

To install the kernel headers needed by vmware tools run uname -r (to get kernel name) and apt-get below. Might end up needing to do this even after a 'sudo apt-get install build-essentials' when you update to a leading edge kernel via 'sudo apt-get dist-upgrade' or manually. I added build-essential to apt-get because you always need it for vmware tools.

$ uname -r
3.5.0-46-generic
$sudo apt-get install linux-headers-3.5.0-46-generic build-essential

To correct "Error: Unable to execute "/usr/bin/vmware-uninstall-tools.pl." do a sudo copy of the vmware-uninstall-tools.pl from the new vmware tools you want to install to the location it is looking for it (typically /usr/bin)

As an example, I usually open a terminal and change directory to /tmp then click on VMware menu Manage then option "Reinstall VMware Tools..." then (once VMware mounts its CDROM of latest tools) copy tar from read-only CDROM to /tmp as below (based on a version 9.6.1-1378637)

$ cd /tmp
$ cp /media/my_username/VMware\ Tools/VMwareTools-9.6.1-1378637.tar.gz .
$ tar -xzf VMwareTools-9.6.1-1378637.tar.gz
$ cd vmware-tools-distrib
$ cp bin/vmware-uninstall-tools.pl /usr/bin/
$ sudo ./vmware-install.pl
| improve this answer | |
1

The vmware install script checks if the package is present on your installation. The solution is to purge the package:

sudo dpkg --purge open-vm-tools
| improve this answer | |
0

copy uninstall script from vmware-tools-distrib/bin/ to /usr/bin as following command:

cp path_to_extracted_vmware-tools_dir/bin/vmware-uninstall-tools.pl /usr/bin/.

then run install script again.

| improve this answer | |
0

This was caused by me killing the install (CNTRL C) because I forgot to add -d to automate the install with defaults. The initial run of the script creates the /etc/vmware-tools folder, because that exists the script thinks vmware-tools is already installed.

Simple answer is: sudo rm -R /etc/vmware-tools

then re-run the installation script.

| improve this answer | |
0

I ran into this when I upgrade the version of VMWare on my host, and followed its instructions for updating the client.

After I'd mounted the virtual CD image, untarred and ran the installed, I saw the message:

The installer has detected an existing installation of open-vm-tools packages on this system and will not attempt to remove and replace these user-space applications. It is recommended to use the open-vm-tools packages provided by the operating system. If you do not want to use the existing installation of open-vm-tools packages and use VMware Tools, you must uninstall the open-vm-tools packages and re-run this installer. The packages that need to be removed are: open-vm-tools Packages must be removed with the --purge option.

From this it is clear what muast be done to remove them:

sudo apt-get remove --purge open-vm-tools

I did that, and re-ran the installer. And this time I got:

open-vm-tools packages are available from the OS vendor and VMware recommends using open-vm-tools packages. See http://kb.vmware.com/kb/2073803 for more information. Do you still want to proceed with this installation? [no] no

So I gave up on installing the client software from the virtual ISO in the host, and just ran

sudo apt-get install open-vm-tools

IOW, the right answer for this issue isn't to find a way to work around installing the vm tools from the host ISO, but to not install the vm tools from the host ISO, but to update the open-vm-tools package, instead.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.