3

I tried this link, but got the following message on shell:

sudo apt-get install python-pip :

vineet@vineet:~$ sudo pip install --upgrade pyusb
Downloading/unpacking pyusb
Could not find a version that satisfies the requirement pyusb 
(from versions: 1.0.0a2,   1.0.0a2, 1.0.0a3, 1.0.0a3, 1.0.0b1)
Cleaning up...
No distributions matching the version for pyusb  
Storing complete log in /home/vineet/.pip/pip.log

I want to use pyusb 1.0(or above,if it exists(i am a newbie)) which is written in python. Also will I need libusb to run pyusb? Please tell me how to download that too! I have tried an failed in both cases.I am using Ubuntu 13.10 so please respond accordingly.

2

I found the answer myself:

I found this link wherein the whole procedure is outlined. Providing a gist here:

  1. Download, extract and install libusb 1.0.9 from here: libusb.org

  2. Download, extract and install pyusb 1.0 from here : SF pyusb project. This link also contains a link to a tutorial for pyusb.

  • Would you accept this one too :). – user.dz Jan 30 '15 at 11:04
0

Not sure if this works on 13.10 but the method below works fine on 14.04.

sudo apt-get install python libusb-1.0-0-dev
git clone https://github.com/walac/pyusb
cd pyusb && sudo python setup.py install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.