I was trying to fix my audio problems using suggestions from this forum. One of the comments suggested I execute this and only this:

killall pulseaudio

So I did, and I restarted my computer just in case, but all it did was remove my soundcard and I still couldn't hear anything. Now I don't know how to get my soundcard back.

Please note that I am extremely inexperienced when it comes to Ubuntu.

  • 3
    What sound card do you have? pulseaudio should automatically restart when you stop (kill) it like that. You can look at this - help.ubuntu.com/community/SoundTroubleshootingProcedure. Although it sounds "simple", be sure to make sure sound is not muted.
    – Panther
    Feb 26 '14 at 16:40
  • 1
    killall pulseaudio should only kill the current running Pulseaudio process - not disable the sound card...
    – Wilf
    Feb 26 '14 at 16:55

From a forum thread, open a terminal and type:*

sudo apt-get purge pulseaudio
sudo apt-get clean && sudo apt-get autoremove

Reboot. Open a terminal again and type (ignore any errors with the rm command):

rm -r ~/.pulse ~/.asound* ~/.pulse-cookie ~/.config/pulse
sudo apt-get install pulseaudio
sudo alsa force-reload

The last command should restart the PulseAudio server and launch a desktop application for its settings. Another thread notes that there might be conflicts with IPv6. If so, then edit /etc/avahi/avahi-daemon.conf and set use-ipv6 to no:


Restart the avahi-daemon (e.g., reboot again).

Make sure that the audio devices are not muted.

*Note: Using apt instead of apt-get may work as well.

See also:

  • 1
    In case anyone has the issue of changed System Settings after this, follow this link: askubuntu.com/questions/453440/…
    – runDOSrun
    Feb 3 '15 at 0:18
  • +10 This answer really ought to get the green tick. You just resolved my issues with sound on Ubuntu 16.04. The sound settings icon was greyed out on the top left corner in the desktop, and the "sound" settings did not show my built in audio, or my other sound output options like blue tooth Bose speakers etc, but following your steps exactly fixed the problem. May 5 '17 at 23:10
  • This worked for me running ubuntu gnome + wayland on the dell xps 13 2016. Looks like the function keys aren't working for volume control now lol. One thing at a time I suppose.
    – davidawad
    Jun 23 '17 at 14:24
  • it worked for me, ubuntu 17.04 Aug 17 '17 at 6:27
  • If you have bluetooth you'd need to install pulseaudio-module-bluetooth as well. It was missing on my system after the above fix. sudo apt install pulseaudio-module-bluetooth
    – Diego
    Aug 10 '18 at 15:06

Try out the Ubuntu Software Center (easiert way to go for a beginner) at the tab "installed" search for pulse and you can select the entry and click "remove".

After removed, simply search for pulse again and install it.

  • 2
    removing pulse audio as you suggest is almost certainly not going to solve the problem and is almost certainly going to remove a large number of dependencies with it. Probably better to reinstall - sudo apt-get --reinstall pulseaudio . Reinstalling is not going to affect any user settings as they are in /home , so it the problem is with a user setting, such as mute, the problem will persist.
    – Panther
    Feb 26 '14 at 19:48
  • 1
    That's reinstall without dashes @Panther - sudo apt-get reinstall pulseaudio Jul 29 at 10:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.