1

The Problem:

Unable to launch Everpad on 64bit Ubuntu 13.10. I get the below error:

$ everpad
Traceback (most recent call last):
  File "/usr/bin/everpad", line 9, in <module>
    load_entry_point('everpad==2.6.1dev', 'gui_scripts', 'everpad')()
  File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 353, in load_entry_point    
  File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 2321, in load_entry_point
    return ep_map
  File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 2048, in load
    if req.specs: raise ValueError
  File "/usr/lib/pymodules/python2.7/everpad/pad/indicator.py", line 8, in <module>
    from everpad.pad.editor import Editor
  File "/usr/lib/pymodules/python2.7/everpad/pad/editor/__init__.py", line 6, in <module>
    from everpad.interface.editor import Ui_Editor
  File "/usr/lib/pymodules/python2.7/everpad/interface/editor.py", line 125, in <module>
    from PySide import QtWebKit
ImportError: cannot import name QtWebKit

What I have tried so far:

Interestingly, I tried testing Everpad in a live boot and still had the same issue. The latest repositories just do not like the PySide module.

I did have an issue beforehand where it failed because it couldn't even see the PySide module in Python. However I managed to work around the PySide install and got to the latest error of not being able to import QtWebKit from PySide. I have found the below link which managed to get me to this stage.

https://github.com/nvbn/everpad/issues/401

Thought the issue could be to do with the PySide install not having the .egg-info. Apparently something to do with the way apt-get installs python-pyside. However it doesn't seem to install the PySide.QTWebKit module correctly. Also get this problem from pip install pyside. The link above pretty much just suggests installing PySide via pip install pyside but I seem to have problems directly with importing QTWebKit from the PySide module in the python interpreter.

Other things I have tried:

I have tried linking from the QtWebKit that I found in /usr/local/lib/python2.7/dist-packages/PySide to /usr/lib/python2.7/dist-packages/PySide but that just resulted in a 'Segmentation failure' when launching Everpad.

Anyone that understands the PySide module/Python/Everpad able to shed some light on this one? Is it my PySide module just not installing correctly?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.