0

I'm working on Ubuntu 12.04 x64 and when I'm trying to run Skype there's following message in terminal: skype: error while loading shared libraries: libgstbase-0.10.so.0: cannot open shared object file: No such file or directory I've tried reinstalling and purging but it doesn't work.
Can anyone explain what is wrong and what should I do?

0

The .so file that exists but was reported as "doesn't exist" because it was incompatible with the system architecture. It was a 32 bit version, but you have a 64 bit operating system. According to the documentation on the Skype website, there is a simple solution.

Open a terminal (ctrl + alt + t) and run

dpkg --add-architecture i386
apt-get update
apt-get -f install skype

Source

  • Thank you for reply but it seems like my dpkg doesn't have this option: dpkg: error: unknown option --add-architecture – user252582 Feb 26 '14 at 16:13
  • This didn't work for me. I still get the same error on opening Skype. I notice that at no point did my problematic shared lib (libsqlite3.so.0) get reinstalled. I removed skype and reinstalled, same thing. I cannot "apt-get remove libsqlite3.so.0", it says "you have requested an impossible situation ... unmet dependencies. libatk-wrapper-java : Depends: default-jre ..." – Jonathan Hartley Mar 22 '14 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.