I am running 10.04 with the latest updates on an MSI 1719 (GX700) laptop and am unable to get it to connect to my wireless network.

It sees the available networks and allows me to go through the setup process but always fails to connect after I input the pass key.

As per a response I found here, I am posting the following information:

Output from lsmod:

Module                  Size  Used by
cryptd                  8116  0 
aes_x86_64              7912  54 
aes_generic            27607  1 aes_x86_64
binfmt_misc             7960  1 
ppdev                   6375  0 
dm_crypt               13043  0 
rfcomm                 40393  0 
sco                     9617  0 
snd_hda_codec_realtek   279040  1 
snd_hda_intel          25677  2 
bridge                 53184  0 
stp                     2171  1 bridge
bnep                   11884  0 
snd_hda_codec          85759  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               6924  1 snd_hda_codec
snd_pcm_oss            41394  0 
snd_mixer_oss          16299  1 snd_pcm_oss
snd_pcm                87882  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
l2cap                  34806  4 rfcomm,bnep
snd_seq_dummy           1782  0 
snd_seq_oss            31219  0 
snd_seq_midi            5829  0 
snd_rawmidi            23420  1 snd_seq_midi
snd_seq_midi_event      7267  2 snd_seq_oss,snd_seq_midi
snd_seq                57481  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              23649  2 snd_pcm,snd_seq
snd_seq_device          6888  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
sdhci_pci               6700  0 
btusb                  12969  0 
lp                      9336  0 
snd                    71106  16 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               8052  1 snd
sdhci                  17928  1 sdhci_pci
joydev                 11072  0 
parport                37160  2 ppdev,lp
bluetooth              58685  5 rfcomm,sco,bnep,l2cap,btusb
led_class               3764  1 sdhci
snd_page_alloc          8500  2 snd_hda_intel,snd_pcm
rt2860sta             542482  1 
nvidia              10832442  44 
psmouse                64576  0 
serio_raw               4918  0 
ohci1394               30260  0 
fbcon                  39270  71 
tileblit                2487  1 fbcon
font                    8053  1 fbcon
bitblit                 5811  1 fbcon
video                  20623  0 
output                  2503  1 video
softcursor              1565  1 bitblit
ieee1394               94771  1 ohci1394
r8169                  39650  0 
mii                     5237  1 r8169
vga16fb                12757  1 
vgastate                9857  1 vga16fb
intel_agp              29095  0 

Output from ifconfig:

eth0      Link encap:Ethernet  HWaddr 00:19:db:ee:ec:b3  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:12138 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9408 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:13983048 (13.9 MB)  TX bytes:1515167 (1.5 MB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:717 errors:0 dropped:0 overruns:0 frame:0
          TX packets:717 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:59328 (59.3 KB)  TX bytes:59328 (59.3 KB)

wlan0     Link encap:Ethernet  HWaddr 00:1d:7d:3e:34:86  
          inet6 addr: fe80::21d:7dff:fe3e:3486/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:618331 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30391 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:60888090 (60.8 MB)  TX bytes:507 (507.0 B)

The output from the "route" command and the "cat /etc/resolve.conf" were both blank.

UPDATE As per the suggestions in the two answers provided thus far, I am adding the following information:

Output from lshw -C network

       description: Wireless interface
       product: RT2860 Wireless 802.11n PCIe
       vendor: RaLink
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: wlan0
       version: 00
       serial: 00:1d:7d:3e:34:86
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2860 latency=0 multicast=yes wireless=RT2860 Wireless
       resources: irq:19 memory:f9ef0000-f9efffff
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: eth0
       version: 01
       serial: 00:19:db:ee:ec:b3
       size: 10MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10MB/s
       resources: irq:30 ioport:d800(size=256) memory:f9fff000-f9ffffff memory:c0a00000-c0a1ffff(prefetchable)

Output from cat /etc/network/interfaces

auto lo
iface lo inet loopback

Output from iwconfig:

wlan0     RT2860 Wireless  ESSID:""  Nickname:"RT2860STA"
          Mode:Auto  Frequency=2.437 GHz  Bit Rate=1 Mb/s   
          RTS thr:off   Fragment thr:off
          Link Quality=100/100  Signal level:-84 dBm  Noise level:-87 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Output from lspci | grep Network

06:00.0 Network controller: RaLink RT2860 Wireless 802.11n PCIe

I have verified that the package "wpasupplicant" is installed.

And I initially thought that it must be a problem with my router so I did a hard reset on it and set it up from scratch with basically just the defaults so I seriously doubt that's the problem.


6 Answers 6


Since ifconfig shows wlan0, I think that the driver is installed and working, so there is probably some other problem...

So, just an initial stab at eliminating the most common problems:

  1. Have you installed the package "wpasupplicant"? This package provides functionality for encrypted network connections (WPA)

  2. Have you manage to successfully connect to the network before? If the router you're trying to connect to has a MAC-filter (i.e. the router is setup to only allow connections from a configured list of computers/network cards), you may need to properly configure the router...

  3. If none of the above works, you may try installing the package 'linux-backports-modules-wireless-lucid-generic'


  • Would you look at the posted feedback? I have the wpasupplicant module installed. Commented Sep 17, 2010 at 14:41
  • 1
    Have you tried setting up the router with not encryption, just to see if that is the problem. You problem could be related to: bugs.launchpad.net/ubuntu/lucid/+source/…
    – Nicke
    Commented Sep 18, 2010 at 7:56

Try downloading the latest drivers from Ralink.com. I have an MSI with a similar card and had to build the drivers from source. It's very easy to do, and it now works perfectly.


you should be able to find more info in the syslog. For example, when I connect to a network, it shows this:

Sep 17 15:13:11 excelsior NetworkManager: Activation (wlan0) successful, device activated. Sep 17 15:13:11 excelsior NetworkManager: Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete.

after some other messages about DHCP and address info.


I've experienced difficulties with Realtek wifi-card on Ubuntu 9.10/10.04. Following this guide at least made the wifi-card usable. Limited support in 9.10/10.04 for my Realtek card is a known issue. I often, but not always, lost connection, when my session timed out.

Workaround (9.10/10.04): I simply turned off the wireless access and turned it on again using NetworkManager applet. Not elegant, but it worked.

Solution: Upgrading to 10.10 (beta) has provided flawless support so far.


Ok, ruling out the simple things...

Have you actually checked that the transciever (router) is not of the older wireless systems? (Wireless A, B, etc etc).

I'm unaware of your network situation, or your level of knowledge; but a similar sounding problem I know of was resolved due to the older router being unable to make sense of wireless N devices.

Also, early wireless devices are unable to connect to multiple machines.

Again, apologies if that was a patronizing answer, but it can't hurt to help! :)


Install this kernel please:


RT2860 driver in Ubuntu 10.04 has issues that prevent it working. Just installing this kernel should provide you with a working system.

Not the answer you're looking for? Browse other questions tagged .