5

i just recently installed ubuntu 11.04, english version that comes with libreoffice.

I also installed Greek language.

Is there some way to make Writer recognize my input language (English - Greek) and apply spelling check on the fly, according to my input language?

For example, i type a sentence in English, then switch keyboard input (Alt-Shift) and type a sentence in Greek. Writer does no recognize the Greek sentence and underlines it red.

MS Office and OO under Windows does it... As soon as you change input language (keyboard layout), the real time spelling checker changes also between languages...

Thank you in advance...

  • When you installed the Greek language, did you do so via the languages app? I've installed Korean on my machines in addition to English, and OOo automatically switches languages for me when I switch my input method. Since OOo has no spellcheck for Korean, I can only guess that that would work. – Scott Severance May 14 '11 at 8:02
  • I'm glad that this is not the default behaviour. I'd prefer to set input and spelling languages independently of each other. Tying them together is potentially unexpected and confusing behaviour. – David Foerster May 30 '18 at 16:03
1

Don't know about Libreoffice (it should be almost the same as OO) but I can suggest you a tool for global language autospelling. It is called Xneur - the same as PuntoSwitcher for windows.

  • thank you for your prompt reply... apparently Xneur does not support greek...:-( – Kosmas Papagiannis May 14 '11 at 7:13
1

In OpenOffice under Ubuntu 10.10 (and earlier) you can change the 'Deafault' style character settings including the language. In theory every style is based on it so your whole document will have Greek language set by default.

0

Perhaps you need to install a Greek dictionary. Have you though of that? In the software centre you will find this: Greek (el_GR) dictionary for MySpell.

I know that Openoffice and Libreoffice now use Hunspell but Wikipedia says:

Hunspell is based on Myspell and is backward-compatable with MySpell dictionaries.

I hope this helps.

Regards.

0

I am still amazed that after all these years this issue has not been resolved. What Kosmas is asking for is very reasonable and very clear. He just wants to write a document that contains mixed (English and Greek) words in the same paragraph and he does not want to mark each word and change spell checking language manually. It's as simple as that.

  • English layout = English spellchecking
  • Greek layout = Greek spellchecking

Automatically!

It has nothing to do with xneur (this is simply used to change the layout automatically. Not the spell checking language).

Solutions:

  1. Get WPS office for Linux. Works like charm.
  2. Download Orthos English/Greek combined dictionary from here. It's a workaround, but it works. Make sure that you download the GR/EN combined file. You will then have to install it a Libreoffice extension (just run the downloaded file and it will be done automatically)

I have really given up hope that this will ever be fixed :-(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.