4

How can I install my 3G Modem (D-Link DWM-157)? Some steps I've already tried:

  • Plug in the modem (green light is fired);
  • Run sudo su command;
  • lsusb (command line) - my USB-device is found ("Bus 003 Device 010: ID 2001:a707 D-Link Corp.");
  • Mounted it (ran mount /dev/sr, then press Tab some times - "sr0" and "sr1" are displayed in terminal line; Unplug the USB-device and repeated previous operations: only "sr0" was shown in the terminal window);
  • /media/cdrom now has "3g_modem_connect_D310A_amd64.deb" and -//-//-_i386.deb files (my OS type is 64-bit, but I tried both versions); I've been trying to install it as from Ubuntu Software Center, using dpkg -i command with both versions of files - "Install finished." was displayed.

After all this, in "Network Manager" my USB-device is not shown... (after unplugging the device and plugging it in again, only a red light is on).

  • Isn't there a install.sh script on the modem – user3620828 Jul 5 '16 at 11:22
  • I use the same Device (D-Link) but on Arch Linux, It works fine after installing packages given here (Under Network manager). And one more thing, When I connect this Dongle, I get also get a medium with 2 debain packages and 2 rpm packages (for i386 & amd64), do you get them too?? have you tried installing it ? – Severus Tux Jul 7 '16 at 4:33
1

I am running the 157 on Mint 16 now, working fine, but the install not smooth: installed the .deb no problem, nothing happened though- no detection by network manager. Had to unplug eth0 and reboot- then Network manager detected it.

The documentaion for this device is close to non-existant, playing around I discovered a more elegant solution (but still not perfect):

The software installs a script: 3g_connect.sh

Run 3g_connect.sh form the terminal:

3g_connect.sh 003:010

ie the arguement to 3g_connect.sh is the BUS:DEVICE pair from you post:

my USB-device is found ("Bus 003 Device 010: ID 2001:a707 D-Link Corp.")

Note: The 3g_connect.sh script should be run as root for it to work, but running it as a normal user did force Network manager to detect the dongle- and I could then use Network manager to manage it- which I prefer).

Hope this helps.

| improve this answer | |
  • There is a simpler solution (again not perfect- as I figure out more I will post): kill modem-manager, restarts and detects the dongle) – user171357 Mar 25 '14 at 18:37
0

You seem to have installed the drivers for the device already. But from what i've read about other 3G modems, to activate the modem you first need to eject the virtual cdrom. Sometimes followed by a usb_modeswitch command.

But i'm just looking to get one, so i haven't had the joy to try this myself :-). This looks like a good one for a good price (€50 at a local store), would be interested to know if it works properly on ubuntu

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.