1

I want to install gfortran-4.4.1 on Ubuntu 12.04 (Precise Pangolin). But the only versions available in repositories are 4.4.7, 4.5 and 4.6. However gfortran-4.4.1 can be easily installed via apt-get on Ubuntu 9.10 (Karmic).

So I tried, to replace etc/apt/sources.list with the one from Karmic. When I did sudo apt-get update everything worked fine, but when I tried to install gfortran I kept getting error messages like:

Depends: [package name] but it is not going to be installed.

I tried to remove those packages and reinstall older version of them, but it didn't seem to help.

Do you have any suggestions?

  • This is not possible. – Registered User Feb 26 '14 at 9:40
  • Any comments on that? – user252484 Feb 26 '14 at 10:05
  • 1
    packages are build for specific versions.They don't work on other versions.You may get the source code for karmic and rebuild it for pangolin.But outright installation will not work. – Registered User Feb 26 '14 at 10:08
0

As mentioned in @Registered User comment: The answer is there is no way to install a package available in Ubuntu Karmic on Ubuntu Precise Pangolin.

You CAN however build from the Karmic source code.

You can also run Karmic on a VM under Virtual box and install and run your favourite Karmic apps in that fashion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.