It's too small to read.

Bug report is https://bugzilla.mozilla.org/show_bug.cgi?id=143119

Notice: it's not about Firebug.

up vote 3 down vote accepted

In Firefox 27, Codemirror is now deployed as the default code editor:

Codemirror

Codemirror is a popular HTML5-based code editor component used on web sites. It is customizable and theme-able. The Firefox Devtools now use CodeMirror in various places: Style editor, Debugger, Inspector (Edit as HTML) and Scratchpad.

From the Option panel, the user can select which theme to use (dark or light).

Source: Firefox Developer Tools: Episode 27 – Edit as HTML, Codemirror & more


This works for me in ~/.mozilla/firefox/profile-name/chrome/userChrome.css.

@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document regexp("chrome://browser/content/devtools/.*"){
* { font-size: 20px !important }
}

enter image description here

The easiest workaround for me was changing DPI value in KDE font settings. Now all other fonts are too big but at least I can read the debugger.

  • 2
    I think your correct edit was rejected because I was editing to add extra info. Sorry about that. I made the edit you suggested. – DK Bose Feb 26 '14 at 11:52

You can also create userChrome.css in:

/usr/lib/firefox-dev/browser/chrome/ (32 bit)

/usr/lib64/firefox-dev/browser/chrome/ (64 bit)

It worked for me when I created userChrome.css in /usr/lib64/firefox-dev/browser/chrome/ folder. This should also make your changes global.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.