There are three primary users of my Ubuntu 13.10 Cinnamon 2.14 install: me, my wife, and our oldest daughter.

Everything seems to work just fine unless we change users. When one user is active, we press the usual CTRL+ALT+L (or select from the GUI). If switching to a non-logged in user, it's fine: Enter password once on Greeter, load desktop.

When switching back to a user that was already logged in and active, enter Greeter password, then enter password again to unlock screensaver when other active user's desktop loads. Under older versions I didn't have to do double-duty when switching between active users and wonder if there is some side effect I've missed because my 13.10 was originally Unity, which I hated, nuked entirely, and replaced with Cinnamon.

Any thoughts, suggestions, ideas or recommendations would be welcome!

System Details:

root@OptiPlex-GX620:~$ Linux OptiPlex-GX620 3.12.6-031206-generic #201312201218 SMP Fri Dec 20 17:20:06 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
root@OptiPlex-GX620:~$ dpkg -l | grep cinn
ii  cinnamon                                                    2.0.14-20131203040025-saucy                      amd64        Cinnamon desktop
ii  cinnamon-common                                             2.0.14-20131203040025-saucy                      all          Cinnamon desktop (Common data files)
ii  cinnamon-control-center                                     2.0.9-20131124013238-saucy                       amd64        utilities to configure the Cinnamon desktop
ii  cinnamon-control-center-data                                2.0.9-20131124013238-saucy                       all          configuration applets for Cinnamon - data files
ii  cinnamon-dbg                                                2.0.14-20131203040025-saucy                      amd64        Debugging symbols for the Cinnamon desktop
ii  cinnamon-desktop-data                                       2.0.4-20131124011540-saucy                       all          Common files for Cinnamon desktop apps
ii  cinnamon-screensaver                                        2.0.3-20131105013303-saucy                       amd64        Cinnamon screen saver and locker
ii  cinnamon-session                                            2.0.6-20131124043042-saucy                       amd64        Cinnamon Session Manager - Minimal runtime
ii  cinnamon-session-common                                     2.0.6-20131124043042-saucy                       all          Cinnamon Session Manager - common files
ii  cinnamon-settings-daemon                                    2.0.8-20131203004543-saucy                       amd64        daemon handling the Cinnamon session settings
ii  cinnamon-settings-daemon-dev                                2.0.8-20131203004543-saucy                       amd64        Headers for building applications communicating with cinnamon-settings-daemon
ii  cinnamon-translations                                       2.0.3-20131203040238-saucy                       all          Translation files for the Cinnamon desktop
ii  gir1.2-cinnamondesktop-3.0                                  2.0.4-20131124011540-saucy                       amd64        Introspection data for CinnamonDesktop
ii  libcinnamon-control-center-dev                              2.0.9-20131124013238-saucy                       amd64        utilities to configure the Cinnamon desktop
ii  libcinnamon-control-center1                                 2.0.9-20131124013238-saucy                       amd64        utilities to configure the Cinnamon desktop
ii  libcinnamon-desktop-dev                                     2.0.4-20131124011540-saucy                       amd64        Utility library for loading .desktop files - development files
ii  libcinnamon-desktop0                                        2.0.4-20131124011540-saucy                       amd64        Utility library for loading .desktop files - runtime files

Any other details I've missed (if any) can be provided if you need them.


  • 1
    Not sure, but try to disable lock screen. – g_p Feb 25 '14 at 14:49
  • It is a feature, not a bug =) It increases security. Disable your screen saver or configure it so as to not require a password when you resume the session. – Panther Feb 25 '14 at 17:05
  • Not an option (see img link). I can either disable the screensaver password entirely, or I can disable when waking from suspend, but no session options. Is that something I'll need to set using the Tweak Tool? image – Seann Feb 25 '14 at 19:14
  • disable the screen saver option entirely – Panther Feb 25 '14 at 22:12
  • You can file a bug report on launchpad – Panther Feb 25 '14 at 23:15

Well, as it turns out, this issue was caused by having both light-locker and cinnamon-screensaver installed. I removed light-locker, and now my issue is resolved. The problem is that light-locker apparently doesn't have any settings you can set and just reads the general screensaver/brightness settings.

Thus, when the screensaver time-out hits the allotted time, the system activates what are in essence two screensavers, requiring two password entries, but only one has settings you can manage.

Naturally, I overlooked light-locker at first because of it's lack of dedicated settings interface and didn't clue in until I was reading about somebody else having gnome-screensaver and cinnamon-screensaver both installed and having the same issue I was when I realised that light-locker is forked from the Gnome 3 gnome-screensaver project. Because light-locker is just a blank screen, I didn't realize there were two screensavers running.

As I said though: removed light-locker and solved the problem.

  • Thank you. Thank you. Thank you. In my case it was gnome-screensaver on 14.04 with Cinnamon. I removed it leaving cinnamon-screensaver in place. – Rick Apr 28 '14 at 21:19
  • @Richard: Glad you were able to get it resolved! Unrelated note - Perhaps you can tell me how you switched 14.04 from Unity to Cinnamon? I tried and bricked my machine, forcing me to go back to 13.10! – Seann Apr 29 '14 at 1:27
  • 1
    @Seann: you really do not need to remove packages to solve the case. You just need to know where is the desktop entry. In this case - /etc/xdg/autostart/light-locker.desktop, and edit apropriately, ie. include entry: OnlyShowIn=Unity; – Petr Matousu Feb 1 '15 at 8:12
  • @PetrMatousu Thanks, except that /etc/xdg/autostart/light-locker.desktop doesn't exist on my current 14.04 install, as light-locker isn't installed by default. – Seann Feb 3 '15 at 18:58
  • @Seann Well, you can create it if necessary. On trusty, the file exists after desktop installation. Anyway, this is why root user exists. The right of admin is to adjust the system by configuring or adding system files. Though it requires lot of knowledge and reading to do it properly and it might not be for everyone. I remeber you removed light-locker, maybe the file was uninstalled as well. – Petr Matousu Feb 3 '15 at 21:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.