5

I have tried several solutions posted in the possible duplicate, but It does not work for me for the bluetooth timeout part, and my system have more problems than that. See details at the end of this question.

I know my laptop does not have bluetooth support, but the system always try something like waiting for bluetooth to be ready, which results in following error when system start up:

INFO @wl_cfg80211_attach : Registerted CFG80211 phy
Bluetooth: hci0 command 0x1003 tx timeout

When I select to start ubuntu at the grub menu, the screen is empty for about 15 seconds and then above messages show up one by one, seconds between.

I tried to the bluetooth off from the top bar of ubuntu system, but It is turned on again after restarts.

I also tried three solutions posted in How can I deactivate Bluetooth on system startup? But none of them fix my problem.

  1. add rfkill block bluetooth to /etc/rc.local file, before exit 0. This does not have any effect.
  2. add echo disable > /proc/acpi/ibm/bluetooth to /etc/rc.local file, before exit 0. On first restart, the second message disappears, but wait time remains. On second restart, same symptom as before.
  3. add blacklist btusb to the end of /etc/modprobe.d/blacklist.conf. The second message disappears on starts up, but wait time remains, and there is still an option saying "Turn Off Bluetooth" in the top bar everytime I login.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.