3

I am stumped with this situation. I have a new Canon Pixma MG5300 inkjet printer which is connected via USB. Anything else than PDF works perfectly fine: Ubuntu printer test page, LibreOffice files, web pages, Gimp images.

But it won't print any PDF file, from any PDF-viewer app.

When I print a PDF file, the printer wakes up just as usual, and the display shows "processing" as usual. But the output tray does not open (it usually does), and after a few seconds the display just goes back to idle. The file disappears from Ubuntu's print queue just as if it had been printed.

  • I've tried removing the printer and letting the computer rediscover and reinstall it.
  • I'm using default printer settings.
  • I've installed a number of PDF viewer apps from the Software Center, just to rule out that the built-in document viewer is to blame.
  • I've tried with a wide variety of PDF files -- some generated by SimpleScan, some downloaded from the Internet.
  • The printer also has a WIFI interface, so I've tried installing it as a WIFI printer and use that instead of via USB. No difference.

What can I do to troubleshoot this?

  • Ubuntu 13.10 detects and correctly identifies the printer, and provides drivers for it. I have not tried to find alternative drivers yet.
  • Honestly, I wouldn't have an explanation if this would work, but did you try printing from a terminal using lpr -P PRINTERNAME whatever.pdf? – Klaus-Dieter Warzecha Feb 25 '14 at 8:49
  • 1
    @KlausWarzecha: Thanks, I usually don't use the command line but I will try that this evening and report back. – Torben Gundtofte-Bruun Feb 25 '14 at 8:50
1

A little research shows that Canon releases a Debian printer driver. The release date is 2011 so I am unsure that it would be any better than the driver in Ubuntu 13.10 though.

Downloads for MG5300 series (select OS = "linux"):
http://www.canon.co.uk/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MG_series/PIXMA_MG5350.aspx
(This page says MG5350 but the listed drivers are for the whole MG5300 series.)

Direct download link:
http://www.canon.co.uk/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MG_series/PIXMA_MG5350.aspx?DLtcmuri=tcm:14-863341&page=1&type=download

There's also this scanner driver, but it might not be needed because SimpleScan works fine already:
http://www.canon.co.uk/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MG_series/PIXMA_MG5350.aspx?DLtcmuri=tcm:14-863345&page=1&type=download

1

According to Canon's MG-series printer documentation, Canon MG printers have a strange limitation that the only PDF files that they can print are PDF files that have been produced by Canon's own "IJ Scan" or "My Image Garden" software. PDF files produced by all other software cannot be printed. Even PDF files which are imported into IJ Scan from other applications and saved, cannot be printed. There seems to be no workaround or alternative solution, except to buy a printer from another manufacturer.

Reference:

  1. "Printing Documents (PDF files)", page 442, Canon MG7550 manual, URL (as of September 2015): http://gdlp01.c-wss.com/gds/3/0300015853/02/MG7500ser_OnlineManual_Mac_EN_V02.pdf also via http://www.canon.co.uk/support/consumer_products/products/fax__multifunctionals/inkjet/pixma_mg_series/pixma_mg7550.aspx?type=manuals&language=undefined
0

Johns answer gave me some hope that it could be possible to fool the printer to accept other pdfs. (Spoiler: No)

I scanned a PDF (good.pdf) to a USB-stick and looked inside it. (it is able to print pdf files the scanner has produced)

After some fooling around I found out that the printers "first line of defense" simply checks the pdf metadata.

This script adds correct pdf metadata to an existing pdf file:

#!/usr/bin/env bash

META="[ /Creator (Canon SC1001) /Producer (MG5300 series) /DOCINFO pdfmark"

gs -dSAFER -dBATCH -dNOPAUSE \
   -sDEVICE=pdfwrite \
   -dCompatibilityLevel=1.3 \
   -sOutputFile="$2" "$1" <(echo "$META")

Also converts the pdf to version to 1.3 since that was the version of good.pdf

This gets me to the print menu, but unfortunately it fails there.

I guess the restriction was there for a reason :D The printer is probably really picky about what kinds of pdf it can handle.

I digged a bit deeper in case anyone wants to pick this up:

$ qpdf --show-pages --with-images good.pdf 
page 1: 4 0 R
  images:
    /Im1: 5 0 R, 1240 x 1754

$ qpdf --show-object=5 good.pdf                     
Object is stream.  Dictionary:
<< /BitsPerComponent 8 /ColorSpace /DeviceRGB /Filter /DCTDecode /Height 11 0 R /Length 7 0 R /Subtype /Image /Type /XObject /Width 10 0 R >>

$ file =(qpdf --show-object=5 good.pdf --raw-stream-data)            
/tmp/zshVemxbQ: JPEG image data, Exif standard: [TIFF image data, little-endian, direntries=8, manufacturer=Canon, model=MG5300 series, software=1.01, xresolution=135, yresolution=143, resolutionunit=2], baseline, precision 8, 1240x1754, frames 3

I then tried to no avail to make imagemagick's convert to produce a pdf containing the same type of image data

Note: this is a Canon Pixma MG5350

-3

Simple solution.

Download Adobe Reader (it's free) and then you can print from there.

You can also control which pages to print, orientation etc.

  • 2
    OP claims that he can't print from "any PDF-viewer app" and the accepted answer from question author himself implies that it was a printer driver issue. Also, I doubt that Adobe has somehow implemented better support for Linux' printing subsystem (in an application that they abandoned years ago) than the developers dedicated to open-source applications like Evince, Okular, Xpdf or lpr. – David Foerster Dec 11 '16 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.