3

EDIT - The file is being saved to the desktop but is being placed in the region above DVI-I-1, i.e. the bit that is described by +0+261 offset. Temporary solution is just to align monitors along the top end. Is there a fix for this, is it a known issue or should it be made known to Ubuntu/Nvidia devs?


My desktop size is greater than my monitor size. Consequently, when I save a document the icon is not available onscreen, although the file is present via an 'ls' at the command line. I am running a dual monitor setup, see the output from 'xrandr -q' below. Ubuntu version 13.10, Graphics card, GeForce GTX 650 Ti/PCIe/SSE2, driver is nvidia's.

I have tried running

xrandr --output DVI-I-1 --mode 1600x1200

followed by

xrandr --output DVI-I-1 --mode 1680x1050

in an attempt to reset the screen size appropriately but this makes no difference.

I also include a dump of ~/.config/monitors.xml below which seems to my uneducated eye to be in order.

Can anyone suggest what I should try next to resolve this?


$ xrandr -q
Screen 0: minimum 8 x 8, current 2760 x 1920, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1680x1050+0+261 (normal left inverted right x axis y axis) 474mm x 297mm
   1680x1050      60.0*+
   1600x1200      60.0  
   1400x1050      60.0  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   640x480        75.0     72.8     59.9  
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected 1080x1920+1680+0 left (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      60.0*+
   1680x1050      60.0  
   1440x900       75.0     59.9  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     60.3     56.2  
   640x480        75.0     72.8     59.9  

$ less ~/.config/monitors.xml

<monitors version="1">
  <configuration>
      <clone>no</clone>
      <output name="DVI-I-0">
      </output>
      <output name="DVI-I-1">
          <vendor>HSD</vendor>
          <product>0x2469</product>
          <serial>0x01010101</serial>
          <width>1680</width>
          <height>1050</height>
          <rate>60</rate>
          <x>0</x>
          <y>261</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="HDMI-0">
      </output>
      <output name="DVI-D-0">
          <vendor>IVM</vendor>
          <product>0x5620</product>
          <serial>0x00001c82</serial>
          <width>1920</width>
          <height>1080</height>
          <rate>60</rate>
          <x>1680</x>
          <y>0</y>
          <rotation>left</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>no</primary>
      </output>
  </configuration>
</monitors>
  • In my experience sudo nvidia-settings can often be a better way to edit these settings. – bacon Feb 24 '14 at 17:37
  • @bacon I've identified the cause of the issue using your tip. Any further suggestions? – lovelyzoo Feb 25 '14 at 21:59
  • Would you mind posting an (anonimized?) screenshot, it will show the show the Desktop area. AFAIK tt should contain dark regions for the unused areas. This will surely help the readers of your question to understand the problem more fully. Also, Why is there a vertical offset of 261 anyway? :-D – bacon Mar 2 '14 at 17:14
  • @bacon Thanks for the suggestion but I cannot post images, I don't have +10 rep. I have moved the left hand monitor down a little in the layout so as to match the physical setup. Hence the 261 is being added to the offset. Is it the case that the nvidia driver cannot cope properly with one monitor in landscape and the other in portrait? – lovelyzoo Mar 4 '14 at 15:36
  • upload a screenshot to imgur.com and post the link here. We'll do the rest. Thank you – Elder Geek Jul 15 '14 at 12:48
5

NOTE: I'm answering this question because it is the first result that appears in a google search.

I had this same problem and I spent ages searching for a way to fix it within Ubuntu to no avail.

Turns out though that it can be solved by looking at the settings of the monitor/TV you are using. Not the Ubuntu settings, the actual built-in settings for the display that you access by pressing the physical buttons on the display.

For me I had to change the aspect ratio settings from 16:9 to "Just Scan". Not sure what it means, but it did the job.

  • You saved my life. On my old Hyundai N220W, I had to press the button Menu > Reset, and press button Auto. After hours spent trying command lines and tweaking xorg.conf etc., I wish your answer were more visible/widespread. – Georg Mar 15 at 23:00
0

well, in my case the settings on the TV did not allow to resolve the issue so i have resolved it with manipulation with xrandr

xrandr --output HDMI-0 --set underscan auto

in your case try with correct display DVI-I-1 instead of HDMI-0 hope it helps

0

Also had xrandr -q report larger resolution than my display could give:

# xrandr -q
Screen 0: minimum 320 x 200, current 1366 x 1024, maximum 8192 x 8192
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768      60.00*+
...

This command solved the problem:

xrandr --size 1366x768

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.