It worked, the it dropped, then it worked, now it won't connect to wireless. Brand new Asus laptop that came with ubuntu is connected. The problem seems to be with Ubuntu. It keeps asking for authorization codes for my neighbors signals as well as my signal which the asus is connected to.

  • > Blockquote Use the address (MAC address) you found to place in BSSID in Network Manager > Blockquote In the answer above, why is the hotspot showing a different MAC address than the one found with the "iwlist wlan0 scan" command? Thanks.
    – user296844
    Jun 22, 2014 at 13:24
  • 1
    The "Device MAC Address" listed in the picture is the MAC address for the wireless adapter on the device. The hotspot's MAC address was entered into the "BSSID" box, and matches what was output by iwlist. Jul 7, 2014 at 15:34

2 Answers 2


If your wireless drops because it is attempting to roam to the neighbor's access point, I suggest you ask your wireless to bind to your access point. Right-click the Network Manager icon, select Edit Connections. Fill in the MAC address for your access point; find it with:

sudo iwlist wlan0 scan

For example:

Cell 05 - Address: 00:13:19:F2:2E:D0
                Frequency:2.437 GHz (Channel 6)
                Quality=66/70  Signal level=-88 dBm  
                Encryption key:on
                ESSID:"UCInet Mobile Access"

Use the address (MAC address) you found to place in BSSID in Network Manager:enter image description here

Save and close.

  • 1
    I've written a bash script that will do this automatically. It will check the strengths of any found access points for the given network SSID and ask if you want to update the setting to its MAC address. This would be useful if you move around a lot and want to ensure you have the strongest signal. Usage: ./set-access-points.sh [network SSID] [network interface id = wlan0] gist.github.com/archy-bold/9a4cdee49309e4a2d059c900362fa9dc
    – Simon
    Feb 1, 2018 at 12:25
  • 2
    This solution did not work for me. I mention this because down-voting is not constructive.
    – psiphi75
    Mar 14, 2018 at 2:57
  • Note that this still works with the new network manager in Gnome-based versions of Ubuntu (17.10+). In fact the BSSID field is a drop-down so you don't necessarily have to copy-paste the BSSID, as long as you know part of it. Mar 24, 2018 at 15:23

After trying all sorts of suggested solutions, finally, it worked (30 minutes, no drop; earlier there was a drop every <2 minutes) after restarting the wifi modem.

  • Hello. Nice that it does that but how is this an answer to the question asked?
    – David
    Mar 31, 2022 at 14:36
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. Once you have enough reputation, you can also add a bounty to draw more attention to this question. - From Review
    – David
    Mar 31, 2022 at 14:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .