24

When I try to upgrade my ubuntu 13.04 to 13.10, it gives the following error:

It was not possible to authenticate some packages. This may be a 
transient network problem. You may want to try again later. See below 
for a list of unauthenticated packages.

Also while downloading the files, I see such errors like:

Err http://in.archive.ubuntu.com saucy-backports/restricted Translation-en_IN 

I tried the link to a similar question but that does not work. I don't think I have any troubles with the keys.

  • you need to do a update before upgrade – user224465 Feb 24 '14 at 12:49
  • I have tried that several times already. But I get a pop-up saying that softwares updates are no more available for this version and so upgrade. – Singularity Feb 24 '14 at 15:31
  • Run in terminal sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade, then try upgrading with sudo do-relase-upgrade – kubahaha Feb 25 '14 at 16:14
  • I tried all that but no luck. Finally the answer posted by me below worked out. – Singularity Feb 25 '14 at 23:06
43

Important Security Notice

This answer will disable an critical security feature in Ubuntu. It will stop Ubuntu checking packages are the the same as they were when they were built.

This could mean your updates are compromised or corrupt.
This could mean there's just a bug in the way Ubuntu's release upgrades are handled.

I'm not saying you should never do this, I'm just asking you to be aware of what you're doing. And put things back after you upgrade. Don't leave AllowUnauthenticated on indefinitely.

— Oli, Ask Ubuntu mod.


This worked out for me.

create the file /etc/update-manager/release-upgrades.d/unauth.cfg as root and add the following.

[Distro]
AllowUnauthenticated=yes

After upgrade, remove this file.

  • 4
    Be very careful doing this. There's a reason why the package manager is rejecting the upgrade -- it cannot verify authenticity. This workaround will allow you to install packages, yes, but you have no guarantee that the packages are not malicious. In other words, don't do this unless you know what you are doing. – rduplain Dec 14 '15 at 18:45
  • This answer provides an upgrade path without allowing unauthenticated. askubuntu.com/a/91821/113086 – rduplain Dec 14 '15 at 20:02
  • @rduplain, nope that does not work for me – Gabor Dec 28 '15 at 18:43
  • 2
    @rduplain Update from: ubuntu 10.04 lts --> 12.04 lts it seems to that some versions need this bypass entry... i don't know why – user516073 Mar 8 '16 at 8:41
  • I also couldn't get the cdromupgrade from the 12.04 LTS CDROM to even start upgrading from 10.04, without this hack... much appreciated (now on to see if I can rename the mount point so it matches the CDROM image name (help.ubuntu.com/community/…), else the update fails next with packages not being found) – sdaau Mar 25 '16 at 15:58

protected by Byte Commander Mar 8 '16 at 8:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.