I'm trying to install a program from the *.x86_64 file but it seems I don't have the right permissions to do it.

Even if I right-click and go in the "Permission" tab, when I try to change anything (Either any of the drop down menus or the "Execute" check box) it just change right back to the previous state (unchecked).

When I try to :

gksu nautilus

to change the permission under superuser, it just crash :

Nautilus-Share-Message: Called "net usershare info" but it failed:
'net usershare' returned error 255: net usershare: cannot open
usershare directory /var/lib/samba/usershares. Error No such file or
directory Please ask your system administrator to enable user sharing.

** ERROR:nautilus-properties-window.c:1837:schedule_owner_change_timeout:assertion failed: (NAUTILUS_IS_FILE (file))

Then I tryed to change permissions and ownership of the folder using different ways :

sudo chmod -x *.x86_64


chmod -R 777 (folder)

nothing changes.

When I use on the folder I get:

ls -l 
drwx------ 1 psyc0p4th psyc0p4th       4096 Jan 29 06:38   (folder)

When I try it inside the folder (where the files are), I get :

-rw------- 1 psyc0p4th psyc0p4th 83827576 Jan 29 06:37 sounds.dat

on every single files.

Those files come from a downloaded tar.gz. The tar also have the same problem.

I tried to decompress using different program (xarchiver, p7zip, the tar command line) and I have the same result. The only thing different is that in xarchiver, the permissions are listed as "-rwxr-xr-x" but not after the decompression.

Other infos :

psyc0p4th@psyc0p4th-X550CA:/$ mount 
/dev/sda3 on / type ext4
(rw,errors=remount-ro) proc on /proc type proc
(rw,noexec,nosuid,nodev) sysfs on /sys type sysfs
(rw,noexec,nosuid,nodev) none on /sys/fs/cgroup type tmpfs (rw) none
on /sys/fs/fuse/connections type fusectl (rw) none on
/sys/kernel/debug type debugfs (rw) none on /sys/kernel/security type
securityfs (rw) none on /sys/firmware/efi/efivars type efivarfs (rw)
udev on /dev type devtmpfs (rw,mode=0755) devpts on /dev/pts type
devpts (rw,noexec,nosuid,gid=5,mode=0620) tmpfs on /run type tmpfs
(rw,noexec,nosuid,size=10%,mode=0755) none on /run/lock type tmpfs
(rw,noexec,nosuid,nodev,size=5242880) none on /run/shm type tmpfs
(rw,nosuid,nodev) none on /run/user type tmpfs
(rw,noexec,nosuid,nodev,size=104857600,mode=0755) none on
/sys/fs/pstore type pstore (rw) /dev/sda1 on /boot/efi type vfat (rw)
systemd on /sys/fs/cgroup/systemd type cgroup
(rw,noexec,nosuid,nodev,none,name=systemd) gvfsd-fuse on
/run/user/1000/gvfs type fuse.gvfsd-fuse
(rw,nosuid,nodev,user=psyc0p4th) /dev/sr0 on /media/psyc0p4th/Perfect
Stranger type udf
/dev/sda6 on /media/psyc0p4th/DATA type fuseblk
/dev/sda7 on /media/psyc0p4th/Restore type fuseblk
/dev/sda2 on /media/psyc0p4th/Recovery type fuseblk

psyc0p4th@psyc0p4th-X550CA:/$ arch 

I also tried doing all of that logged in as root, no result.

I've been using Linux for about a month now, so i'm pretty new to all this, if you need any other informations just ask. Thanks for everything.

  • Is this a .deb file? Are you running dpkg -i <file name>.deb?
    – allejo
    Feb 24, 2014 at 1:19
  • No, the compressed files are .tar.gz (tarball?). The files inside are either a .i686 or .x86_64.
    – PsYc0p4tH
    Feb 24, 2014 at 14:49

2 Answers 2


I just solved the problem. I moved the files from the Downloads directory to Home directory. I can now change all the permissions for all the files, and execute the .x86_64 file.

I found the idea there : Permission Denied when using ./configure Thanks!


Open a Terminal (Ctrl+Alt+T) and navigate to directory where tar.gz at using cd for example: cd /home/yourname/Downloads/ and do next:

if you need to install tar.gz or tar.bz2:

If it's tar.gz use

tar xvzf packagename.tar.gz

if it's a tar.bz2 use

tar xvjf packagename.tar.bz2

and then



sudo make install

though I advise to use Chekinstall sudo aptitude install checkinstall it's even recommended. And instead of make and sudo make install use sudo checkinstall because it stores your manual installations to the system which can be easily removed then.

  • There is no install file and/or configure file. The aptitude install checkinstall fails, and the sudo checkinstall as well : ========================= Installation results =========================== make: *** No rule to make target `install'. Stop. **** Installation failed. Aborting package creation. Cleaning up...OK Bye.
    – PsYc0p4tH
    Feb 24, 2014 at 17:36
  • it's not a file! you need to run this in Terminal :-) wait a sec I'll re-edit the post
    – JoKeR
    Feb 24, 2014 at 17:38
  • Ok, sorry, i get it. It still doesnt work : bash: ./configure: No such file or directory
    – PsYc0p4tH
    Feb 24, 2014 at 17:41
  • read now the answer
    – JoKeR
    Feb 24, 2014 at 17:42
  • also do consider installing Checkinstall it's just my advise you decide :-)
    – JoKeR
    Feb 24, 2014 at 17:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .