8

I am not a fan of unity so I decided to install gnome 3 on my PC which is running Ubuntu 13.10. But after the installation, I am failing to use some shortcuts like Ctrl+Alt+T to open the terminal and others for volume. Would someone help me please.

7
  • Are you able to set the shortcuts in Keyboard Settings?
    – Wilf
    Commented Feb 23, 2014 at 22:51
  • when i go to keyboard settings, Ctrl+Alt+T is already set for terminal launch. even in dconf editor.
    – Azarial.MW
    Commented Feb 24, 2014 at 14:10
  • Add a custom launcher to run gnome-terminal instead, then asign it to Ctrl-Alt-T
    – Wilf
    Commented Feb 24, 2014 at 15:56
  • thank you so much wilf, but how do i do that? would you explain a bit.
    – Azarial.MW
    Commented Feb 24, 2014 at 18:59
  • still not working......
    – Azarial.MW
    Commented Feb 27, 2014 at 19:42

3 Answers 3

12

EDIT: The easier way is reloading gnome shell using Alt+F2 (and then r)

Older way:

Same is the case for me. Try this

  1. mv .gconf/ .gconf.bak

  2. Logout and Login back.

It worked for me in Ubuntu Gnome 14.10.

Source : https://unix.stackexchange.com/questions/126127/global-keyboard-shortcuts-in-ubuntu-14-04

3
  • 1
    alt + F2 then command r worked fine, thanks.
    – cprn
    Commented Jan 14, 2015 at 18:47
  • note for dumbs like me: type a lowercase "r"
    – laconbass
    Commented Mar 3, 2018 at 9:14
  • "Alt+F2 r" no longer works with Wayland. Commented May 18, 2023 at 22:24
1

Open Keyboard Settings, and go to Shortcuts.

Click the + to add a new one, enter this, and click 'Apply':
'Open Terminal' under Name, and 'gnome-terminal' under Command

Then click 'Disabled', and press Ctrl+Alt+T to assign that keyboard shortcut.

If it prompts, press 'Reassign':

1
  • I tried this, the short cut is listed in the list of shortcuts, but the key combination just doesn't activate it. what do I have to do to activate the shortcut? I tried rebooting, log-out and back in... nothing worked
    – NeStack
    Commented Dec 3, 2021 at 13:36
1

In my case the gnome-settings-daemon process was hang:

 0 D alex   3798  3587  0  80   0 - 472136 rpc_wa Apr18 tty2    00:00:17 /usr/libexec/gnome-settings-daemon

I just killed it and it reloads automatically. After that everything is working properly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .