I'm trying to install TeamViewer on Xubuntu 13.10, 64 bit version. There is "known" problem with the 64 bit package on their website, hence its advised to install the 32 bit version. (As explained here: Installed Teamviewer using a 64-bits system, but I get a dependency error)

I've followed all the steps in the above listed answer, but I end up getting the following error, when using gdebi (or other errors in "manual mode"):

Cannot install 'libc6:i386'

I'm trying to use apt-get install on this lib give various errors.

How can this be solved?


I have Xubuntu 13.10 64 bit, just like yours, I guess, I got teamviewer to work on my machine, and I did that just because I promised to give you an answer :)

First, I downloaded this TeamViewer, then I opened a terminal and did:

sudo dpkg --add-architecture i386 and then sudo apt-get update

and then I used Gdebi to install TeamViewer, it downloaded all the dependencies, you can find Gdebi in the software center and yes you don't need gdebi, you can use the software center or dpkg to install the package, I'm used to Gdebi, old habits die hard.

In case you still see that libc6:i386 error, download Synaptic package manager from software center too, and make sure that, the packages marked in blue are installed

enter image description here

At least that's how it works on my computer. I don't really know if you need both packages, or only one or maybe another one, I don't know, and I don't care as long as it's working.

  • thanks a lot for your help ! I appreciate your efforts. Sadly, it's not working on my machine )-: The "bottom" package - "32 bit shared" is already installed. And I've already re-installed various times. But I dont see the "top" package, and I cannot find it. Can you tell me which archive are you using in "sources.list" ? I've tried few archives/mirrors, but with no success. Thanks again for your help. – John D. Feb 26 '14 at 20:46
  • @JohnD. Ok I'll get back with you soon, but for now, can you please run sudo apt-get upgrade and then sudo apt-get update and then sudo apt-get -y install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++6:i386 libx11-6:i386 libglib2.0-0:i386 libfreetype6:i386 libSM6:i386 libXrender1:i386 libfontconfig1:i386 libXext6:i386 libcups2:i386 p11-kit:i386 libcap-ng0:i386 gnome-keyring:i386 – Lynob Feb 26 '14 at 21:35
  • @JohnD. because I had your error when I tried to install KingSoft Office on my machine, so i installed these stuff and it worked - you can skip libfreetype and all that stuff afterward – Lynob Feb 26 '14 at 21:36
  • the "apt-get -y install..." gave me this message: ========== 0 upgraded, 10 newly installed, 1299 to remove and 0 not upgraded. Need to get 5,313 kB of archives. After this operation, 1,808 MB disk space will be freed. E: There are problems and -y was used without --force-yes ========== From the last line I understand it was not executed, but the remove of 1299 looks bit scary, so I've decided not to do it for now. Anyways, I cant believe I say it, but the horrible WinSXS looks friendly now... I'm going to give it another try or 2, and then skip TeamViewer and stay with putty )-: – John D. Feb 26 '14 at 22:25

It look like there is no a package, as sysads.co.uk reports:

On newer 64-bit DEB-systems with Multiarch-support (Debian 7) teamviewer_linux_x64.deb cannot be installed because the package ia32-libs is not available anymore on these systems. In this case you can use teamviewer_linux.deb instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.