3

This question already has an answer here:

I have ubuntu server 12.10 and installed ubuntu-desktop to access it via GUI and changed the default runlevel to 5. Now I get the GUI login screen with my username (display name) but when i enter my password the screen just flicks and comes back to login screen ( doesnt give me any error). the same user works fine with same credentials in CLI.

strange thing is when i click on guest, it logs me in straight away and works fine.

Any solution please.

PS: I am new to Ubuntu/linux, Keeping in mind, please be basic and simple.

marked as duplicate by Eric Carvalho, karel, Avinash Raj, Maythux, belacqua Mar 5 '14 at 22:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

8

This looks like the .Xauthority file is corrupted. Try this in a tty:

sudo mv .Xauthority .Xauthority_backup

Then restart lightdm and try to log in again:

sudo service lightdm restart

If that was not the cause, restore the file to its previous state:

sudo mv .Xauthority_backup .Xauthority
  • 1
    Hi darent. thankyou for your reply but unfortunately No success with it.. – user251447 Feb 23 '14 at 16:24
  • 2
    Yes , this was the problem and it worked ..thanks for sharing... – Buminda Jun 2 '15 at 1:31
  • wow!!! This is a terrible user experience!!! wondering how many gurus we need around just to be able to log into a linux distro. thanks for the fix! – Lucas Pottersky Oct 25 '17 at 11:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.