14

So im trying ubuntu again after being off it for awhile in win7 i can set gpu fan to 10-30% and its barly reaching 52c , however with ubuntu nvidia set it to 55% wich is really loud on my msi 460gtx.

This is the only thing that keeps me from using ubuntu is there really no program or way to set manually like msi afterburner / evga precision , temperature curve & fan speed?.

Default fan is way to loud and its barly 3 c diffrence from 25% gpu fan speed to 55% but the noise is alot more.

21

In the terminal run:

sudo nvidia-xconfig
sudo nvidia-xconfig --cool-bits=4

restart your computer and search for NVIDIA X Server Settings in the Dash. There should be an option to change fan speed under Thermal Settings.

1
  • 6
    To provide some more explanations: This will generate a completely new xorg.conf and also adds Option "Coolbits" "4" to Section "Screen". And the application called NVIDIA X Server Settings is nvidia-settings.
    – scai
    Nov 18 '15 at 14:43
3

Be careful about the highest voted answer. I have two 2080ti GPUs and running that command made my computer unable to boot.

Finally, I found an answer from here. Following that:

  1. Create a file named /etc/X11/xorg.conf.d/11-nvidia-coolbits.conf and write the following in it:

    Section "OutputClass"
        Identifier "nvidia"
        MatchDriver "nvidia-drm"
        Driver "nvidia"
        Option "Coolbits" "4"
    EndSection
    
  2. Log out and log back in.

  3. Run nvidia-settings. In the windows that opens you can now find the fan speed control options. Only the fan speed of one GPU can be controlled though.

1
  • Worked for me! Strange that the fan speed slider only appears after that and not always
    – xjcl
    Jun 9 '21 at 23:45
2

Try sudo apt-get install nvclock

1
  • 6
    it says, Unable to locate this package.
    – Kongsea
    Dec 1 '17 at 12:20
2

To control Nvidia GPU fan speed via Terminal on Linux Mint 20 with a 1070 Ti:

sudo nvidia-xconfig --cool-bits=4

to tell nvidia-xconfig to allow the fan to be controlled in the command line. You may need to reboot here.

nvidia-smi

Gives information about the GPU(s) and their numbers. Importantly I note that my 1070 Ti is GPU 0.

nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUTargetFanSpeed=55"

For a much more detailed overview of this feature including multiple GPU fans, check out this thorough documentation Nvidia Overclocking and Cooling

For a somewhat rambling and wayward thread which lead me to the above link, check out Set Fanspeed in Linux from Terminal

==================END OF ANSWER==================

And as an extra tidbit not asked for in this question, you can also adjust the power output of your Nvidia GPU with:

sudo nvidia-smi -i 0 -pl 90

Where the 0 is my GPU number, and the 90 is the maximum power in watts. If you set this too low, you will get an error. In my limited experience, setting it too high had no effect. I found I can get 95%+ performance for ~75% energy cost by setting the power level to 100 in the above command in my mining rig, but I imagine other power conscious users would appreciate this too.

0
  1. Install nvclock as someone above pointed out
  2. Open terminal
  3. nvclock -f -F 80 (in this case, fan would run @ 80%)
2
  • I have Sony Vaio with Geforce 310m. The same issue. When I use nvclock I am getting the reply: $ sudo nvclock -f -F 80 Unable to shadow the video bios Error: Your card doesn't support fanspeed adjustments!
    – Oleksa
    Sep 1 '13 at 8:20
  • Your answer could be improved with an edit , Please organise the answer to make it a little bit of trustful !
    – Someone
    Oct 30 '21 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.