21

I am trying to install gtk-server. First I typed the command ./configure and then make, but when I typed command make install it gave me this error:

osama@osama-HP-Compaq-6910p:~/Downloads/gtk-server-2.3.1-sr$ make install
/usr/bin/install: cannot create regular file `/usr/local/bin/gtk-server': Permission denied
mkdir -p /usr/local/bin
/usr/bin/install -c gtk-server /usr/local/bin
/usr/bin/install -c stop-gtk-server /usr/local/bin
/usr/bin/install: cannot create regular file `/usr/local/bin/stop-gtk-server': Permission denied
make: *** [install] Error 1

1 Answer 1

33

If you are installing an application and used ./configure without the --prefix= option the make install process will install the compiled files in to the predefined paths in your system's file system.

Because you are installing to your system's file system you need special permissions for writing the files, try:

sudo make install

This will elevate your user's permission to root and allow the compiled files to be installed in directories that your user does not have permissions to do so.

You can clearly see that the issue is a permission problem by the error message (cannot create regular file cannot create regular file /usr/local/bin/gtk-server and /usr/local/bin/stop-gtk-server): the user that is trying to install these (in this case you) does not have permissions to write on those directories.

2
  • bruno it worked . i tried sudo make install. thanks
    – osama
    Feb 22, 2014 at 20:43
  • 2
    Bruno, I'm trying to make install Qyoto and I'm getting the same complaint. I've run it with sudo, and I've tried sudo su, but always the same result. Is there any other circumstance that you know of for this problem? Nov 19, 2015 at 0:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.