0

But this happens:

Edit item description here

Would anyone know what to do, I do not know too very much about terminal, so please be patient. Running Ubuntu 12.04 64x AMD.

0

Open Terminal and (as it says in the error message) run sudo service vboxdrv setup.

The reason you see this error is because the kernel was recently upgraded, but the VirtualBox driver was built for the older kernel (which you are no longer running). Normally, dkms automatically recompiles any modules for newer kernels, so you don't have to do it, but (like me) it's not happening. Make sure dkms is installed (sudo apt-get install dkms).

  • tried to run sudo service vboxdrv setup but got vboxdrv: unrecognised service Screenshot from terminal: imgur.com/rhCV4Hj – BigDoge230907 Feb 22 '14 at 19:41
  • It seems you have the version that is in the main Ubuntu repos. In that case, follow the solution here. – saiarcot895 Feb 22 '14 at 19:44
  • 1
    no suitable module for running kernel found after sudo apt-get install virtualbox-dkms should i continue with sudo modprobe vboxdrv anyways? – BigDoge230907 Feb 22 '14 at 19:50
  • No. You need to install the headers for the current version. sudo apt-get install linux-headers-generic. This will also automatically install headers for future kernels. – saiarcot895 Feb 22 '14 at 20:12
  • Dont think it worked, imgur.com/nqPJ5vI – BigDoge230907 Feb 22 '14 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.